Yet Another MIDI issue, I know, but this one is weird

Here is the issue:

I have an Arturia Keystep. Using CV and Gate outputs, the synth works as it should.
Under MIDI, there is nothing. I am using CH1, but tried several different channels. The learning apparently worked, but it took several minutes for the LED to start blinking again (timeout?).

  1. Here is what works: MIDI is read by the MCU, because I can read it on the MIDI out. Exactly what key I am hitting, note on, etc is reflected immediately on the output MIDI port. [So MIDI channel is working to MCU]

  2. The voltage on the DAC (IC20, pin 8) does not change. It stays at 0.579V when I push any key

  3. IC20, pin 1= 4.982V, pin 2 = 4.191V, pin 3 = 0.040V, pin 4 = 4.925, pin 5 = 0V, pin 6 = 1.806V, pin 7 = 0V and pin 8 = 0.579

  4. All power checks out, on all points in the troubleshooting sheets

  5. There is continuity from IC23-15 to IC20-2, and from IC23-13 to IC19-2

I double checked resistors, etc… I am at a loss. Both the DAC_Pitch signal and external VCO_CV_IN are supposed to go to IC6 on pin 2 (after a couple resistors). Again continuity is good.

Here is another thing, under auto tuning, there are two tones, a low and a high. The voltage for the high tone (At VCO test point or IC20-8) is at 0.579V and drops to 0.156 V for the low tone. Tells me the DACs are likely working.

The tuning cycle never stops, just plays two tones, each for about 6 seconds. I can change the pitch by turning the Cutoff up or down.

Anything to point to would be appreciated.

You could swap IC20 and IC19. They are both the same DACs.
But before I would check all other components connected to the DAC output (R60, R57, C30). The DAC_PITCH signal is also going to IC2A (Opamp for VCO_CV_OUT), take it out for testing. Measure also the 4.096 REF voltages.
Check also continuity from the ATmega to the other DAC inputs: SCK (pin3) and MOSI (pin4)

Switched DACS, same result
Pulled U2, Voltages at socket pins are:
pin 1 = 4.010
-2 = 4.050
-3 = 0.001
-4 = -4.949
-5 = Cycles from, 0.403 volts up to 1.130 volts then back down again to
-6 = 4.050
-7 = 4.010
-8= 4.975
continuity on MOSI, SCK, SS1_DAC, SS2_DAC all caps and resistors checked

All 4.096 and -4.096 voltages are measured at sources.
IC1 = 4.090
IC12 = 4.093
IC13 = -4.095

IC6B pin6, has 0.236 Volts while 4.094 volts exists at the other end of R56.
R74 has -4.094V on pin 3, and -3.723 off the wiper and pin 1. There is -0.007v at pin 7 of IC6B
IC6B, pin5 has 0.000V
IC7, pin-1 has 2.371V

I no longer have MIDI coming from the MCU. But I can see it on the scope. I can see the voltage drop when I release a key (on both ends of MIDI). Disconnect the MIDI in, and even pull the OK1 opto-isolator… I have a constant Note OFF on CH1 coming out the MIDI port every second. A clock?

Changed 6N137s, no diff
Changed MCUs, no diff

Dont know if this matters, but on IC22, pin-9 I have a constant 0.315V. If I push any of the momentary buttons, it drops to 0.278. I would have thought that to be a greater difference between high and low. There is a 244.5 Htz signal on the pin. Pushing buttons does change between synth, Keybd, and drum, etc.

This is an Anookum board, but did not know if there was that much of a difference.

Still looking to see what is wrong. I am not sure it is just MIDI that is not working.

There is something wrong, should be also 4.094V on IC6B pin6.
Take IC6 out and measure the DAC_PITCH voltage again, when playing different notes. Best to measure with the scope.

But it is working with CV IN? Strange.

I read your first post again: the strange behaviour could also be the MCU running at a too low frequency. Did you program it yourself. Did you set the right fuses?

I read the make file and only noticed the lock settings, lock:0x2f,

so no fuses are set. Are they set the same way as the Ambika or Shruthi?

efuse :0xfd, hfuse:0xd2, lfuse:0xff

I use the Atmel Studio and ICE to program the boot loader and then the 0.92 ver hex file

You can find the fuse settigs here:
https://github.com/pichenettes/anushri/blob/master/anu/makefile

WooHoo!
Awesome, that was it.

Man, you learn something new everyday, Even if, there was no issue with components… i was still well worth going through this schematic, just to figure out how it is supposed to work.

I never would have figure the fuses, but if I remember now (yes, I should have remembered before), one of the fuses sets the internal clock to the external crystal.

Thank you Sir!!

Glad I could help!
Though you distracted me first with all your DAC measurements, that I diregarded the other symptoms.