Yarns update issue

Hi! So I used c6 to try to load the syx file. Booted up with encoder down, got the snake. Tried to send, got the error message. After multiple fails I gave up. Powered down the module. Restarted the rack and I get nothing on the screen. I can boot into the firmware update mode, but the normal mode won’t turn on. Any ideas?

It’s normal that the module no longer boots normally if you get a transmission error during the update.

What were the timing settings in c6?

Which MIDI interface do you use?

Ah…that makes sense. I was use to how something like braids goes right back if the firmware transmission fails. I’m using a motu midi interface. I tweaked the settings and through experimentation got it to run by slowing the packets as suggested in the manual. I was afraid I did something wrong, because I was just getting that blank screen. I think it’s always just a tad scary when you change the firmware on anything. Luckily your modules are brilliantly designed to prevent such issues.

> I was use to how something like braids goes right back if the firmware transmission fails.

Yarns and Braids work exactly the same way: if the transmission of the first packet fails, nothing has been written so we’re all good, the old firmware is intact. But if the first packet has been received successfully and has been written to flash memory, and the failure happens later (can be as early as the second packet), we’re in a situation in which memory contains some bits of the new code and some bits of the old-code… not good!

I see. Thanks for the insight. Old code plus new code = no Bueno!

Exactly the same has happened to me. I’m using a Scarlett 18i6 interface. I’ve fiddled with the delay setting (up to 200 ms), but I’m still stuck with a blank screen on powering up Yarns. There are various other settings in c6, but I don’t understand them. The interface has worked fine with c6 for updating an Analog Four.

I finally got it work with a 500 ms delay setting. Phew!