Yarns sync issue - Skipping

Hi,
My Yarns is exhibiting strange behaviour.
I have the clock out of output 3 clocking Volca Beats, MIDI out clocking my Microbrute and clock in via MIDI from Ableton.
Everything will be syncing fine and then random skips will occur with the Yarns dropping a beat here and there. I read a thread on Muffs where someone experienced the same problem and it was suggested to set Bar Length to 0. I did this and it seems to lessen the occurances but it still happens randomly.
Is there any idea out there as to what could be causing this? I love my Yarns but this issue essentially makes it useless to me. Hopefully there is a fix.

Sorry, thought I was in Euro modules subforum. Not sure how to delete this?

I’ll have a look at it.

A few people have already reported this but I have never been able to reproduce the problem - I’ve tried to leave it running several times for almost an hour into my logic analyzer, but never observed the issue.

How long does it take before the problem occurs?

I have had the module for 3 months, bought 2nd hand. It only started doing this about 2 weeks ago and would begin in the first ten minutes and occur every 30 seconds or so.
Since changing the bar length to zero it happens once every minute or so, sometimes more, sometimes less.

Have you tried updating the the firmware ?

It’s running the latest firmware,

Wouldn’t it be more logical if you searched in your computer Ableton live setup for the cause? Did you change anything there about 2 weeks ago?

Nothing has changed in Ableton, but I have had a check. The yarns also skips when in sequencer mode with no MIDI plugged in. If I clock from Ableton and use the 4M mode, sending MIDI from Ableton to four different VCO, the skips won’t occur
I’m hoping it’s something that be fixed with a firmware update.

> The yarns also skips when in sequencer mode with no MIDI plugged in

So this means with the internal clock, right?

And by “skips” you mean clock pulses not received by the module connected on Yarns’ clock output; not missing steps in the sequence of CVs sent by the module?

I still haven’t managed to reproduce the issue, I’m really starting to think it is just a matter of making the clock pulses longer.

Yes, this is when synced to internal clock. It also does it in sequencer mode but clocked from Ableton. The only time it doesn’t do it is when I am controlling triggers via MIDI clips in Ableton.
By skips I mean it seems to jump forward a beat so other instruments go offbeat.

For example, I will be sequencing my modular from yarns but clocked by Ableton, clock out from Yarns to Volca Beats and my Polysix sequenced by a Beatstep clocked by Ableton. When the skips occur the modular and Volca will kind of miss or move forward a beat but the Polysix will stay in time so if I am running a bassline from the P6 it will now be on an offbeat, then it will skip again and correct itself.

Actually, my modular seems to not be going out of time, just ran a test with a simple bassline and it ran solid but the Volca skipped to an offbeat.

It’s not possible for me to set the clock pulses to be longer on the module is it? Or does it have to be a firmware upgrade?
Would really love to get this sorted, it kind of makes the module worthless to me and I love everything about it, really want to use it to it’s full potential… I couldn’t sell it in good conscious knowing this issue, no rush at all as long as I know it has a possible fix Yarns shall stay in my rack.
Thanks!

Actually, my hunch about clock pulses was wrong: the clock output sends a square clock with a 50% duty cycle, so the clock pulses cannot be any longer! At 120 BPM, fastest resolution (/96 = 24 ppqn = 48kHz clock), this is 10.4ms, so it’s more than enough!

How easy is it for you to reproduce the problem?

My test setup is this:

  • /16 division for the clock output.
  • Internal clock at 120 BPM, no MIDI plugged in.
  • A “Four to the floor” sequence in the sequencer (one note and 3 rests).

Do you have any oscillator enabled on any channel?

I got this running for entire workdays (first into a frequency counter, now into a logic analyzer) and still no missing pulse :frowning:

Out of curiosity, are you using the start/reset output too? I focused all my attention on the clock output, but I have just identified and fixed an issue with the start/reset output which occurs when B- is set to any value other than 0 or oo

I’m only using it in 4m mode but with clock output turned on and the clock being taken from gate output 3.
No oscillators running.
It is fairly easy to reproduce the problem. It happens every time I play. I use Yarns as my only sequencer and it usually begins skipping within a minute or so.
Is there a way to reset all values to default? I’m sure I have all settings correct and understood but I would love to see if it still happens when Yarns has a clean slate.

Maybe there is one of the 4 memory slots you haven’t written to, in which case you can try loading it.

Next time you’re in a situation when this happens, could you please do any of these:

  • Record on a computer a MIDI dump of the current settings (*> command).
  • Try recording 5 mins of the clock output into an audio interface.

Ok, no problem. Next chance I get i’ll record that.
Thanks for all your help :slight_smile:

I’m sorry to ask you to do this kind of extra work, but I’m completely unable to recreate and study the problem here!

Not a problem at all!