Yarns Midi from logic


Hey, sorry if I sound really dumb here, I nearly gave up with yarns as I am struggling to get it to receive midi from logic. I’m not giving up as I am positive i’m missing something really stupid.

Could someone please please please give me step by step of setting up yarns so that when i send midi from logic it just works, I’ve tried so many things but it docent play ball,

I have other midi devices drum machines etc that work great, but yarns is killing me i just want it to work.

Thanks :slight_smile:


There’s nothing special you have to do. Maybe you have the arpeggiator or sequencer enabled?

Can you also check the channel number on which you’re sending the notes; and if Yarns is set to this channel?


Hey thanks for the super quick response :smiley:
Yes my exact thoughts I know it should be really easy, its sending me crazy haha

Ok I’ve tried so many things now, so how exactly to i make sure the sequencer and arp are fully disabled?

Im pretty sure i have the midi channel set to 13 in both logic and yarns, unlucky number maybe?

I thought maybe i have to send midi clock so i tried that also with no result,



I thought maybe i have to send midi clock so i tried that also with no result,

Well, if you have MIDI clock enabled, and if the tempo is set to external, then Yarns will respond to the MIDI clock and the start/stop messages, and will play a sequence if there is one recorded.

To clear the sequence: press REC twice (ie, record a sequence with no note).
To disable the arpeggiator: set AR to 0.


Just tried exactly this, Im playing a one bar loop,
and nothing just one tone, yarns not flashing, i imagine it should flash when it receives a note,
do i have to do anything tell it to receive the midi?



You need to tell Logic to send to Yarns. Now I don’t have Yarns, but my uMidi and FH-1 show up in this list when I have them plugged in. Go to File - Project Settings - Sync - MIDI


Could this be a hardware problem, I have tried initializing etc i don’t know what to do from here, im pretty confident in sending midi to devices, sending midi on channel 10 from logic to my vermona drm works fine , sending on channel 10 or any other on the same cable and midi port docent work on yarns


Yeah I had it set up like this checked destination then selected the correct midi port


Bummer. I haven’t even messed with different midi channels yet, just got started with modular a few days ago. The few simple tests to see if clocks run and sequences play worked.

There are some other midi options under the track in the inspector. This is for “software instruments”.
There is also the track section of the “external midi”

I just know Logic always seemed a little clunky to set up midi to play with other stuff, especially ReWire.
Sounds like you may have already tried this, just trying to cover all the bases. Hope you get it sorted.


:confused: Yarns won’t show up in this list because it is not a USB device. You’ll see the USB MIDI interface to which Yarns is connected though.

And this is the setting for MIDI clock. You don’t need to transmit MIDI clock…


Are you using macOS or Windows?


Thanks Matthew, Very helpful, I’m getting the vibe something isn’t right with my yarns :confused:
I’m on macOS, i also tried with ableton with the same results, I know my gates / cv outs are working as when playing around with yarns alone i can randomly get it to do things if that makes sense



Transmitting the MIDI clock might be doing more harm than good (because it can trigger the arpeggiator/sequencer if these are active).

If you just want to send notes do not transmit MIDI clock.


If you’re running macOS, try installing Snoize MIDI monitor


And try monitoring the MIDI data sent to Yarns. Can you send me a screenshot?



here is the output on snooze, yep i tried firstly without midi clock and then with, as thought it may rely on it


I may actually have a fault with my midi interface after all of this, somethings not right, i lost connection to my drm and then something was working with yarns, i need to get hold of another midi interface to confirm but ill keep you all updated, thanks for the help everyone


First of all: check another cable. If this is one with molded plugs, you may never notice they’re wobbly. And it’s an easy check…wobbly cables got me to the point where i do only buy cables with screwed plugs.