Yarns - inconsistent LFO speed when used with clock divisions

Hi,

I’m using Yarns in 1M mode and set the output of CV4 as an LFO and its speed a division of the internal clock via the Vibrato Speed settings.

A keyboard controller is connected via MIDI into this module.

The LFO speed cycles in time when a key is held down or a sequence is played by holding down the start/stop button. Or a series of notes held down in quick succession to each other.

However, when a sequence isn’t playing, and I press notes on the keyboard at random intervals without holding down any keys, the LFO speed becomes erratic and different for each note. If i hold a key long enough, the LFO timing will ‘snap’ back correctly.

Is this normal behaviour?

When the LFO speed is set to non-clock divisions, the timing is consistent regardless.

Everything else works fine and really well apart from this. I was hoping to be able to set the LFO speed to a clock division while playing the keyboard without needing to hold notes down all the time, and having varied note lengths.

Hope someone can help, thanks in advance.

> Is this normal behaviour?

Yes. How does the module know that (and when) its internal clock should be running? By default, the clock starts when you press keys, and stops when you release keys (actually, there’s a short interval, half a beat, before which the clock stops, allowing you to keep the clock running without playing completely legato). Because the clock is stopped/restarted at very uneven intervals, the LFO tries to catch up with the change in tempo, until the clock keeps running for long enough (this is why playing along note fixes it).

What you want to do is start the clock manually, and keep it running.

  • Record an empty sequence (press REC twice)
  • Make sure the arpeggiator is not enabled.
  • Press the play button. The internal clock will start, and will continue running while you play… until you press stop.

Fantastic, thanks very much for the quick reply and great explanation!

I just tried your suggestion, works well :slight_smile: