Yarns - how to turn on "steal most recent"

I’ve just purchased a Yarns module. How can I turn on the “steal most recent” polyphonic scheme?

I’m on the layout of 2P and the voicing of POLY, but subsequent notes are stealing the note I’m holding down.

It seems as though it is kinda working. If I hold a note with my left hand and fiddle around with my right hand the left hand note “sticks” until I press two keys too quickly with my right. I hope that makes sense. It eventually steals the left hand note. If I deliberately let go of a note with my right hand and then press a new note with my right hand it works. But if the right hand notes are too quick I will lose the left hand note.

You need to install the latest firmware revision (available here: https://mutable-instruments.net/modules/yarns/firmware/). There is a new voice allocation mode called STEAL MOST RECENT which seems to be exactly what you need.

Ah, okay. Do you think even though I recently purchased the module new that it has older firmware?

If this is the case then I’m very excited!

Even if purchased recently, your module might have been manufactured before the release of the latest firmware. The firmware version number is displayed when the module is powered on.

I’ll try installing the newer firmware and will let you know how it goes. Thanks for the help. I’m really excited for this feature.

I was able to successfully install the firmware version 1.5 and can now select the STEAL MOST RECENT option in the VOICING section. When I get a chance I will let you know how it goes playing it.

If anybody is curious, this is what I used to update the firmware:

  • macOS 10.15.7
  • Roland UM-ONE mk2 USB MIDI Interface

I’ve noticed that in 4P using Steal Most Recent that sometimes when I press two keys at the same time it actually only triggers one of the voices. Any idea why this might be happening?