Yarns And Pamelas Workout



I have just bought Yarns to integrate with Ableton Live. Playing notes via midi from Ableton works great.

However I also want clock Pamelas Workout which I use as the main clock for my modular. So I thought I could have Ableton run/clock/trigger Yarns which in turn could send clock info to Pamela.

In 2M mode I thought I could achieve this but it doesn’t seem to work as Yarns is sending midi clock and start from outputs 3 and 4, but Pamela only responds to dinsync clock at 24ppqn.

If it is possible to sync Pamela with Yarns, any help on how to do this would be greatly appreciated.


  • Make you sure you are running the latest version of the Yarns firmware (it should display “02” temporarily when the module is powered on).
  • Set the B- setting (bar duration) to 0. This causes Yarns to keep its start/reset output high while the clock is running; and low, when the clock stops.
  • Set the O/ setting (output clock division) to 96 (24 ppqn).

Then patch Yarns’ clock output to Pamela’s Clock input ; and Yarns’ start/reset output to Pamela’s Run input.

Not that Pamela doesn’t even need 24 ppqn, it can be made to work with lower divisions.


Thanks for the reply.

Yes doing that I am able to get Yarns to run Pamela when pressing start/stop on Yarns.

But the only way I seem to be able to get Ableton to “play/run” Yarns and in turn run Pamela, is to create a midi clip with a sustained note for the whole bar? Or playing midi notes triggers Yarns and Pamela whenever I press a note?

I can’t see anywhere in the manual to set Yarns to external midi clock.



> I can’t see anywhere in the manual to set Yarns to external midi clock.

Really? I searched for “external MIDI clock” in the manual and here is what I found:

Yarns can use either its own internal clock, or an external MIDI clock source. The tempo is adjusted by modifying the TE (MPO) setting. Below 40 BPM, the display shows EX (TERNAL) – which means that the internal clock will not be used and that external MIDI clock messages are expected. Note that the display only shows the last 2 digits of the tempo; but rhythmically blinks – so there’s no confusion between 60 and 160, or 120 and 220! The tempo can also be set by tapping on the tap tempo button on the front panel.


And make sure that Live is actually sending the MIDI clock to start with!


It’s surprising how many problems with Live can be resolved by actually reading the Live manual…


Such programs should force you to go through a tutorial/training before you can use them :slight_smile:


You mean the tutorial they dedicate the right ¼th of the window to when you first start the program?


Did you know some people pay up to $1000 for a hybrid hardware/software “solution” to MIDI syncing simply to avoid reading the manual and/or maybe updating the drivers of their MIDI interface?


Yes I saw that but I assumed there would be somewhere where you have to set it to receive external midi clock. So it responds to midi clock without changing anything?

I have Ableton sending midi via my Focusrite Scarlett. In Ableton midi out ports in preferences, track, sync and remote are all on. Midi clock type is pattern.

My Elektron Rytm is on the same midi out and is receiving midi clock.

When I press a midi note now sending on any midi channel and even without sustaining it, Yarns starts playing? But when I hit the play button in Ableton, Yarns does not respond?

There must be something that I am not setting correctly.


“It’s surprising how many problems with Live can be resolved by actually reading the Live manual…”

I have been using Live since version 1, I know how to use it!


> So it responds to midi clock without changing anything?

No. You have to set the tempo to EXT so that Yarns responds to external MIDI clock. Otherwise, it will use its internal MIDI clock at the set tempo, and the clock will start/stop every time you press a note.

If there is any way of rephrasing the explanation in the user manual, to make it clearer, I would appreciate your suggestions.


Ah my bad, I misread it.

It makes sense but maybe for people like me who need things spelled out, it could read “rotate the encoder to below 40bpm for setting external clock”?

But if no-one else has had any problems then the fault is mine.


@maxland “I have been using Live since version 1, I know how to use it!”

Please disregard my snarky joke; a lot of people seem to have trouble with Live once they start integrating outboard MIDI gear.

@pichenettes It might be helpful to add something like “PLEASE NOTE: If you want to sync Yarns up with an external clock source such as Live, Logic, or another DAW or sequencer, then you should use the EX (TERNAL) tempo mode.”

Your current explanation is perfectly clear, and this would be redundant, but it might help those who are skimming the manual because you’d be explicitly mentioning the most used DAWs.


@t2k: Who are these people who pay for that, and how can we make a “better” solution? Aside form reading the manual. We wouldn’t make money that way. :wink:


@audiohoarder You can find plenty of examples of these people on the Elektron forum. There’s probably no “better” solution to sell to people who believe in this solution because these people believe in REAL HARDWARE and can’t be bothered to read or follow some actual in-depth instructions. They also believe MIDI MUST SUCK because IT IS OLD.


Ok, MIDI is old because it is the best and most well-kept standard in the modern computer age. the only main issue is how little data can be processed at once, but MIDI HD supposedly increased the bandwidth allowing more instructions to be handled per second. Ok, rant over.

So now, how do we make a better solution to “fix” MIDI. Do we just sell a MIDI hub labeled “USB5 - Five pins are better than one rectangle![](” We can even sell converters that will “Update your wimpy USB to USB5)” for a nominal fee.


@audiohoarder I think the problem a lot of people have is that they expect adding their first outboard piece of MIDI gear to be just as easy as dropping in a new soft-synth into their DAW.

For us, it’s obvious why this is not the case, but for them a lot of stuff suddenly doesn’t work properly anymore, they suddenly have to deal with latency issues, and they’ll have to spend time figuring out how MIDI actually works and what its limitations are.

On top of that, a lot of these folks use the cheapest USB MIDI interface available which is likely to introduce timing issues once they start trying to sync up stuff.


True, I will leave it at that. I do find it odd that it is always Live though.


The rule of thumb is that Live in general has some issues when it comes to MIDI unless you start to tweak it. The non-working sysex handling unless you do some hand-waving and mumble a lot while using something like Max4Live is indicative.

Personally I can’t wait to become disappointed by Bitwig :wink: