Two problems with Ambika and SMR4 [SOLVED]

Hi!
I just built an Ambika and it’s been really exciting and exhausting at the same time.

The issues that I have are:

  1. SD slot not working- I’ve tried two cards, SanDisk 4GB SDHC and Toshiba 2GB SD, with both cards, memory displays (empty) patch and when I try to save then it says SD card I/O error.
    The pins are soldered well, I think, but i didn’t solder the last three ones on purpose. But as I understand, Ambika doesn’t use them. So how can I fix that? Should I solder the last ones nevertheless?

2) One SMR4 voice card not having a full spectrum, meaning that I can’t get the VCF to self oscillate.
The symptoms (“when the oscillators are off and VCF set to self oscillate there is only a slight clicking sound with a slight tone, no sustain”)are the same as in this thread:

But the transistors on my card are the right way.
I’ve also built three other cards, and they work as they should be.

I’ll attach two pictures of the same card, sorry for the bad bad quality, my phone does not take any better ones…
Maybe I’ll get better pictures soon.

EDIT: I forgot to mention that this was the first SMR4 I built, and there was a little mistake- when I first inserted the card into ambika, I forgot to insert the TL074 IC. So could that damage the card somehow? I also swapped all the IC’s with the working voice card, but things stay the same.

Hi jjuhkam
Tried to compare your pictures with my voicecard but the quality of the pictures is too bad.
Maybe compare them with your own working voice cards?

I’ve checked and compared it twice or even more and everything seems to be at the right place, with right polarity…
So the only option is, that some component is not working as it should? How can I measure that?

Have you tried to re solder/re heat all solder joints on the Voicecard?

Try the pins on the trimmer?

DMM: Done that, no change.6581punk: You mean resoldering them? I’ve done that also

1/ Have you tried inserting the card once the power is on?

2/ Does the resonance actually do something on the faulty card - as in it’s getting very close to resonance, but not there…

I assume this is self-sourced… Do you have the reference of the caps you used?

When I insert SD card during the power, nothing happens either.

Resonance is there, but very very subtle… It sounds like there’s some kind of low pass filter on it.

But when resonance should be self-oscillating, it doesn’t accour in the extra low notes or anything (therefore it’s not just like some low-pass)

Could be a bad resistor value somewhere, or a bad solder joint, but it’s hard to tell on your photos…

Yeah, sorry about that. I’ll try to get better ones of the main side and back side tomorrow.
Any ideas on SD card thing? I’ll get the picture of that too.

What is the exact reference of the 4050 chip you used? it might be too slow for the SD card signals.

The chip is Texas Instruments 25AT40M E4 CD4050BE

If that’s the reason, which chip comes with your kit?

You need the CD74HC4050. Note the HC.

2 Likes

Ordered a new chip, and IT WORKS! :slight_smile:

Sorry for the delay with the pictures of the SMR4, will be posting them tonight.

Okay, I got some better pictures now…
Yes, the two 220 resistors have changed, but it shouldn’t matter.
I needed to do some component swapping (3x100uF capacitors) since I built the other cards and I didn’t have some of the stuff at that moment.
I also soldered over all the connections, that’s why the transistor solderpoints are round and why there’s so much (pretty ugly) flux residue. But everything has stayed the same- sound is missing the resonance.
Hope you can see something from these pictures now.
One more thing- I think that there can’t be something wrong with the choice of the specific components, because I used the same ones on other cards and they (all 5) sound as they should.

Please


Clean it first than you see the solder mistakes better.

Greets
Andre’

Okay, I’ve now cleaned the pcb, resoldered the “suspicious” joints, got a better picture.
Everything is exactly the same- no resonance on this card.

That joint above the upper center right IC looks suspicious, but it could be the light.

Hi jjunkam -

It looks to me like one of the poly caps is incorrect: it is marked as 104 and the other three are 102 - the 104 is incorrect and will affect the filter.

Mike

EDIT it’s the top left-most one

The two 220 Ohm carbon resistors can also be a problem. They have a wider tolerance (5%) as metal film resistors (1%). R3, R7, R21 and R25 should be preferably all resistors with the same value (±1%).