Trouble Updating Yarns Firmware

I’ve been having some stuck notes on my Yarns which was running v1.02. I figured I’d try to reflash the firmware with 1.02 just to play it safe. I seem unable to get the sysex data onto the device and now do not have a working module. Any suggestions would be greatly suggested.

I’m on a Mac and I’ve tried using both Sysex Librarian as well as the Elektron C6 tool to xfer the sysex data. Both apps successfully transfer the 1.02 firmware. I’ve delayed the data being sent to ~150ms and also reduced transmission speed.

Once Yarns completes receiving the firmware the screen displays OK then hangs on just K.

I would have expected the device to restart after 1 second like the online manual says should occur. However, Yarns appears to just be frozen after receiving the last packets.

When I powercycle the case Yarns is connected to Yarns now has a blank screen. If I powercycle the case with Yarn in it while holding the encoder it briefly says Er and then turns to the snake mode waiting for the firmware.

I’m sort of at a loss for what to do next. Any suggestions would be greatly appreciated!

Update: I flashed Yarns with firmware 1.01 from the MI Website. While the module does reboot and work after the 1.01 firmware the behavior is quite strange. Traditionally, the MIDI notes from my keyboard work perfectly, now it’s sounding like each note is getting a pitch bend and other very odd behavior. I tried updating to 1.02 and ended up with the same problem as before (firmware ends with OK then K and it doesn’t reboot on its own or function once powercycled manually.)

Question: Is it possible the 1.02 firmware posted on the MI Website has a problem? Alternatively, could something be physically wrong with my Yarns?

> Is it possible the 1.02 firmware posted on the MI Website has a problem?

I will give it a try tomorrow, but I’ve got feedback from people who upgraded to it without any issue so I doubt there’s a problem here.

Which MIDI interface do you use?

@pichenettes i have a MOTU MIDI Express XT (just to be safe I also reinstalled the latest drivers.) It’s a rather old model - maybe 10 years? I suspect it’s OK…could try to borrow another MIDI interface.

Looks like it was a MIDI interface issue.

I tried a few more things:

1) installed the MOTU driver and Sysex s/w on another mac. Same results - ie 1.02 ends with OK then K and hangs.

2) Dug out an old Presonus Firebox audio interface from my garage which has a MIDI interface on it. Used Sysex Librarian to transfer over the 1.02 update. WORKED.

Looks like it’s time to consider switching MIDI interfaces. :confused:

I use Alyseum MIDI interfaces, using CopperLan. Even have my Euro set up connected that way.

I use cascaded Unitor-8 interfaces. To be honest: i used a MOTU Timepiece some years ago, but it has proven to be somewhat unreliable that i will never touch MOTU MIDI interfaces again…it did very weird stuff to sysex that caused a lot of pain. I ended up to reprogram all patches in a Poly-800 and an ESI2000 sampler, which cost my 2 days of unplanned work in preparation of a live set - never again !

I am definitely going to pickup another MIDI interface. Yarns is still behaving quite unexpectedly. I hope it’s just the two very old MIDI interfaces I have…

Has anyone tried using a iConnectivity iConnectMIDI2+ it looks kinda interesting…

This is my first post here. i appreciate all ideas and feedback. I have tried to update Yarns to the newest firmware without success. i have tried 2 different midi interfaces. My question is: Does anyone know of a lower priced midi interface that was know to be successful with updating this with the Elektron C6 software tool?
Thank you.

Can you post a screenshot of your C6 settings?

I am having this exact issue. No matter how much delay i throw at it using C6. It goes to the ‘OK’ then half a second later it just says ’ K’ Aaaaand nothing. No reboot. Just frozen. I can still boot the ‘firmware upgrade’ part. but anything else. Gone. Using an old Projectmix I/O.

Kinda frustrating since i use yarns as a daily driver to sync up all of my stuff and was hoping to write some music this evening. And having a gig coming up next week :expressionless:

Trying to see if i can locate my old Machinedrum midi interface somewhere. But i think i might have borrowed it out.

Are the old firmware files anywhere on the site so i can try those out? Can’t seem to locate them.

Any ideas?

It goes to the ‘OK’ then half a second later it just says ’ K’ Aaaaand nothing

there’s a counter being incremented during the update… how high does it go? higher than 60?

Are the old firmware files anywhere on the site so i can try those out? Can’t seem to locate them.

wouldn’t change anything…

It reaches ‘51’ and then goes to ‘OK’ followed by ’ K’

Quick video here.

Delay is at 450ms here. Have tried many other delay values. Same issue.

Alright, headed out to one my friends and tried it with his interface. Worked perfectly fine with 150 ms. A MOTU Ultralight MK3, Cheers.

Trying to update to 1.5 using my old Yamaha/Steinberg UR22 that worked to update to 1.3 but today it is not working. I’m getting the Er error every time. I’m on Windows using C6. I’ve tried two different computers and two different midi cables but still Er. I’ve tried setting the delay from 0 - 1000 with more than a few values between and still Er. I do not know of anyone else with a midi interface I can use.

Edit: Now my Yarns won’t turn on with a normal power cycle but if I hold the encoder it will enter boot mode. Looking for help hopefully in all the right places!

Edit2: This is weird. I tried loading firmware 1.3 and still get the Er message but I just left the unit hanging and after about 15 seconds the snake returned to the display so I rebooted and my Yarns is functioning again. So with that I attempted 1.5 again and get the Er message as usual and I so I wait for the snake to return followed by a reboot and again my Yarns is dead and won’t start normally. So I reboot holding the encoder and attempt 1.3 again, still Er message, then snake, reboot and Yarns is working. I go through the entire process one more time for consistency and sure enough the exact same things happen all over again.

If I leave 1.3 alone I’m good but I’d like to upgrade to 1.5 unless maybe there’s an issue with the age of my Yarns?

The Poly-800 has a well-known buffer overrun issue that can happen with any interface. Excess MIDI data can end up overwriting patch memory, creating sometimes interesting (but usually not) parameter randomisation.