Sysex / midi firmware update fail - bricked for now

Attempted an update to v1.01 from v.98 on a recent 4PM build, and it wont boot normally anymore. I have tried updating many times, both v1.01 and also reverting back v.98, using C6 (with 250 ticks up to 2000 ticks) and Bome’s using Sysex, as well as in Bome’s and the Jazz++ midi player using MIDI.

While updating, the LEDs never blink past 3-5 (this can change each time) and when the Sysex or MIDI is done playing it displays between 3 - 5 LEDs each time, no reboot. Upon reboot, the screen always shows a top row of solid blocks and empty bottom row. After reboot, the LEDs have varied from blank; all are solid;1,3,5,7 only; all LEDs up to S5; or all LEDs were solid and both of the extra internal mod LEDs were solid too.

I do have an interface that was listed as “bad” for Sysex (Tascam US-122), but even the MIDI attempts failed too. I even slowed the MIDI file down to 70 BPM and same result. At this point, Im still hopeful I can update via MIDI/Sysex using a friend’s interface, but Im wondering if any of this behavior indicates the bootloader was wiped?

I haven’t looked into firmware loading in depth, but it seems its a real pita with Windows…

The firmware update procedure over midi always uses sysex. Sysex is a function of midi.
So if you have a bad interface for sysex it won’t work.
You should be OK to do it with your friends interface.

I don’t think you can accidentally overwrite the boot loader unless you are using an AVR programmer via the ISP port. Thus, if you can establish reliable Sysex over MIDI communications, you should be able to recover it.

Well it appears I have no friends with MIDI interfaces handy… Anyone have experience playing MIDI files from iOS devices? MIDI toolbox looks promising.

You will still need a midi interface for that…

Proper SYSEX from iOS devices is not something that is well established at the moment. Additionally, many iOS connected interfaces don’t handle it well (or at all).

If your Tascam is listed as bad for SYSEX transfer, it won’t matter if you’re sending it as a SYSEX or a MIDI file - it’s not going to hand it off properly.

The Roland / Cakewalk UM-1G or UM-One MKII are fairly inexpensive, and when connected with the advanced driver mode, handles SYSEX quite nicely. I usually use the MIDI interface on my MOTU, but I keep one of these around if I need to test something, etc.

Yeah, didn’t quite think through the iOS thing - duh. I ended up trying an iconnectivity mio (no lights flashed) and an m-audio midisport uno (worked like a charm). The new mod destinations are cool!

Ah, yeah, forgot about the mio. That’s another good option. Glad you’ve got it sorted out.

You’ve just failed to upload the main software properly, the bootloader still works. Bricked is when you can’t recover, even with the bootloader has been screwed up you can still use an ISP programmer.

Any of those will work, no need to spend more than 20$ for an USB/MIDI interface :
http://www.thomann.de/gb/esi_midi_mate.htm



http://www.thomann.de/gb/neusonik_umidi_o22.htm

I had the same problem. Bought a Roland UM-One mkII MIDI interface, problem solved.

I do not recommand a low cost interface.

Bought a cheapo USB to MIDI cable on ebay that has been perfectly fine. But I’d look at the MIDIBox blacklist for some examples of interfaces that are buggy:

http://www.midibox.org/dokuwiki/doku.php?id=midi_interface_blacklist

That is a depressively long list …