Superseded: Bees-in-the-Trees 3.z: the post-antepenultimate v3 release candidate


#61

Can I make that request? Alas my FTDI is awaiting pay day to make it arrive.

These changes look absolutely fu#@![](ng awesome)


#62

@stevencrichton, yup, I’ll send you a PM on this forum with links to the binary WAV file. A few obligatory warnings first:

a) as per the license on the source code for this, there is no warranty expressed or implied.
b) installing this will reset the calibration data in your Braids, so you will need to re-calibrate, using the (very straightforward) procedure described in the Braids manual. Likewise, re-installing official Braids firmware will also reset the calibration data, so you need to re-calibrate yet again. However, it only takes a minute or so.
c) If you want to re-install the official Braids firmware, then please re-install the latest v1.7 release, which is here: http://mutable-instruments.net/static/firmware/braids_1.7triple_fix.wav - the reason is that only this very latest version of the official v1.7 Braids code contains the settings checking routine that ensures reversion to the official firmware after installing Bees-in-Trees (or other hacked code) will result is sane settings and a fully functional Braids.
d) although it is now very unlikely that something will go wrong and you end up with a non-functioning Braids, I can offer only advice if that does happen. I can’t offer an unbricking service (well, I could, but I am in Sydney, Australia, and you’d have to post your Braids to me) - that’s why I sought testers with access to FTDI or JTAG/SWD interfaces so they can unbrick their own Braids, just in case. I very much doubt that you will have any problems, but it is best to proceed cautiously. Note also that the fine print in the Braids manual states that Olivier doesn’t offer an unbricking service for Braids that have had alternative firmware installed on them. That said, the likelihood of bricking your Braids when using the audio bootloader is very small - it has been designed to be failsafe. OK, enough warnings.

My suggestion is to:
i) use the audio bootloader, as described in the Braids manual, to first load the very latest Braids v1.7 firmware - see the link above. Verify that works correctly.
ii) practice the re-calibration procedure and verify that has worked,
iii) Then proceed to load Bees-in-Trees version 3v via the audio bootloader.
iv) re-calibrate
v) go crazy with it.

Feedback, bugs reports etc are very welcome. I’d be grateful if you could then, at some stage, re-load the latest Braids v1.7 firmware, again, via the audio bootloader, just to verify that reverting to the official firmware works smoothly - and let me know if it does (or doesn’t). You shouldn’t need to manually reset the stored settings - it should do that automatically when you re-install the latest v1.7 code (and likewise when you install B-in-T 3v). However, if your Braids does seem confused, you can trigger a manual settings reset, in both the latest v1.7 firmware and in B-in-T, by navigating to the version string right at the end of the menu choices, and doing a long-click on the encoder. Warning: this also resets your calibration data, so you’ll need to re-calibrate yet again.

I’ll send you a PM with a link to the compile B-in-T 3v binary in WAV format.


#63

Thanks a million, I’ve already gone up to the new 1.7 already and am waiting to do calibrations when I catch a minute wrapping up the job I’m away to leave. 4 days of writing polygon subdivision for searches hasn’t left me much real time in my life to sit down, wire up the patch bay and do all that kind of stuff.

Yes … I promise to go crazy with it!


#64

Presumably a GIS application? I’ve alway just used the PostGIS extension to PostgreSQL for that sort of thing - works a treat, and uses fuzzy GiST indexes or somesuch, IIRC, to do point-in-polygon determinations very efficiently.


#65

Yup GIS.

I ended up utilising a hughes library to parse it into a SOLR server then combine a whole bunch of other stuff. So you can do both box and poly searches efficiently.

It’s really nice, getting about a 100ms response time doing a 20 value search including long chain keyword strings over about 100k records. All from drawing a polygon on a map.

It’s all to keep a bunch of morons in a sales department happy. Which I hope they are.


#66

Urgghhh, GIS for marketing… I’ve been to a few GIS scientific conferences and half the papers were about selling stuff. At least what you are doing presents an interesting technical challenge.


#67

It’s actually a property rental thing … so it’s doing a quick search to match enquiries to requirement. This way people don’t have to know town names or location radius names. It’s been a nice challenge, mines data forwards and backwards with the GIS with google places etc to allow better accuracy.

I’ll be honest though the fun stuff with SOLR I did on the Tate gallery website to enable abstracts in searches against their collection. 20 people had tried for 6 months to solve even how to search it, I did it in about 2 hours flat. Needless to say there was a lot of lay-offs after that discovery and red faces!

Back on subject though … What a magic firmware! I’ll do the swap back and forth tomorrow and let you know the results, for just now I’ll stick with punishing my ear drums.


#68

Woaw, i’m in love with 1 LFO and color control on bees in trees v3 d, so a 2nd LFO, that´s awsome!
Thanks for this amazing work, waiting for the final wav :wink:


#69

So i load Bees-in-Trees version 3v via the audio bootloader, then latest Braids v1.7 firmware and back to Bees-in-Trees version 3v, no bug to report, everything is ok :wink:
Thanks again, now let’s test it :wink:


#70

@Bmhot, fab! Thanks for doing that testing, very encouraging!


#71

After hours of test, the modulators and functions, are really better implemented than v3d, and gave me a lot of fun with just 1 braids !
The way you can control all the module stuff and can drive you into madness or under control soft modulation, put my braids in another world.
The only bug i found is with META mode, when i used long ratio with ⇑⇓1 and ⇑⇓2, sometime it bug braids.
Thanks again guys for this awesome firmware


#72

Thanks Bmhot. Can you give a bit more detail on what happens in META mode with long ratios, just so I can try to reproduce it?


#73

I test many combinations, always 2 modulators with 1 single parameter control, with some shape settings for⇑SH1 ⇓SH1, and ⇑SH2 ⇓SH2, the META on, sometime turning fine and fm knob, with short or long ratio, i’ve just re-test, it bug my braids.


#74

OK, thanks. What do mean by “bug”? Does Braids hang or crash, or does it make a horrible sound, or something else? Anyway, I’ll try to reproduce the problem. Many thanks again for helping with this - much appreciated!


#75

It crash, no sound, all you can do, is just switching off, hope that help ?
I can try to make a vidéo if you want ?


#76

Tim,
I installed the software and all seems to be working, at a quick glance. In-depth playing starting tonight. Need time to read your awesome release notes and make sense of the whole thing.


#77

@Bmhot, yes, thanks, a short video showing the settings, any CV inputs and what you were adjusting when it crashes. I tried last night to reproduce the problem, but couldn’t. The section of code which controls META mode is unchanged from Olivier’s v1.7 code, so I doubt that is the cause. Which parameter were you modulating with the two internal modulators?


#78

@stevenb, fab! I’ll convert the release notes into a proper meta-manual (a supplement to the official Braids manual) this weekend.


#79

a little video of a crash https://dl.dropboxusercontent.com/u/4021842/2015-01-29%2015.53.58.mov
i only use one parameter per modulator 1 timbre and the other for color.
i think the FM knob CCW with META mode make the crash, maybe because there is
less waveform in bees in trees ?


#80

@BB

Could I request a wav version? I’ve read the warnings and if I do brick it I’ll get a JTAG or whatever and unbrick it myself.