Strange issues after Firmware update

I have never had any issues in the 2 years i have had my Shruthi-1 but this one is really puzzling me.
I had Firmware 1.0 installed and decided to go back to 0.98
About 10 mins before i sent the firmware i made a change to make the Shruthi-1 display the firmware number at boot up.
I sent 0.98 to my Shruthi-1 using C6 just like i always do and as soon as it finished the top of the screen came up with “Programmer” and then lots of random characters on the bottom of the screen.

I managed to fix this issue by sequentially updating from 0.95 to 0.97
But it has not quite fixed it, it seems that whatever version of firmware i use now the Shruthi-1 seems to be self modulating all the parameters and creating a strange bubbly drone noise, even when i have nothing plugged into it other than power

I have done a pretty good search but can not find anything and i am really unsure of what to do next
Thanks

Edit - I think i may have fixed it

I had to make some compromises to make some of the changes in v1.00 possible. One of them is that the system settings are stored differently; making it risky to upgrade/downgrade between v0.9x and v1.0x. Actually, version 1.0x was never meant to be run on the “standard” Shruthi - only on the XT.

So your chip is now in a state in which the system settings are configured for operation with Frank’s XT programmer, ie the CV setting is set to prgm instead of 4cv . You need to change that. It might be difficult to navigate through the menus with this option enabled, but you can still do it by:

  • Grounding the CV1/CV4 inputs to prevent the flickering.
  • Using the encoder.

Thanks for getting back to me so quick, yes that’s what i did to fix it. Seems to be all good now
I did not realise v1.0 did that.

> I did not realise v1.0 did that.

v0.9x and v1.0x are storing settings differently. I removed the “CV” setting in v1.0x, something else is stored in place of that. That’s why the two versions will boot/behave differently from the same block of settings in memory.

I am so sorry about this. I should have said no to new features way earlier, and drew a line by making v1.0x incompatible with the old hardware.

No problem Olivier, it was only a minor hiccup

Hi pichenettes

I have just tried to update my standard shruthi from 0.97 to version 1.01 but eventhough all seems to work the splashscreen with the firmware version number doesn’t show at boot.
I then chose to go for version 0.98 and everything is fine the splasscreen appears at boot time with the 0.98 number showing. I tried again to upgrade to v1.01 but there again no longer splashscreen.

I read above that 1.01 is dedicated to the XT version therefore I will stay with v0.98.

Do you have an explanation for this strange behaviour ?

v1.01 can work on the standard Shruthi too.

> Do you have an explanation for this strange behaviour ?

Yes some settings have disappeared between v0.98 and v1.01; or options have disappeared/appeared for each setting. After having upgraded to v1.01, go to the system settings pages and check that all settings are set to correct values.

@yusynth There is a system setting for startup behaviour in the settings of v1.01

sta (startpage): Selects on which page the Shruthi boots (splash screen, filter page, preset load/save page).

Thanks to both of you pichenettes and shiftr.

OK then I will update to 1.01 and will set the start page option to splash screen.