[SOLVED] uC issues: SCK Fail

So I am trying to flash the control board FW and I am getting this:

c:\\AVR>avrdude -B 100 -V -p m644p -c avrispmkII -P usb -e -u U efuse:w:0xfd:m
U hfuse:w:0xd2:m -U lfuse:w:0xff:m -U lock:w:0x2f:m -F

avrdude: stk500v2_command(): command failed
avrdude: stk500v2_program_enable(): bad AVRISPmkII connection status: SCK fail
avrdude: initialization failed, rc=-1
avrdude: AVR device initialized and ready to accept instructions
avrdude: Device signature = 0x000000
avrdude: Yikes! Invalid device signature.
avrdude: Expected signature for ATMEGA644P is 1E 96 0A

for what ever reason, the programmer and the uC are not getting along, voltages check out, xtal is OK, 18 pF caps OK. Anything else I should check before blaming the uC?

Ribbon cable of the ISP programmer? I need to change it 2 or 3 times a year.

Hmm, I’ve only ever used “-B 10” and not 100, not sure if that makes a difference though…

hmm. will check ribbon. That would be a new one for sure

not the ribbon, flashed a shruthi just fine. Does there need to be a voice card to flash the mainboard FW? Any other dependencies?

No ; but if there is a SD card in the socket this can cause problems (depending on the state in which the 6N138 is at boot, the sd card can “see” the SPI bus).

I’m just having the very same issue trying to flash my Midialf. After some trying my pc tells me it doesnt recognize the usbtinyisp anymore >.<
What could go so terribly wrong when flashing a chip that it destroys your programmer…?
Eh, well, also just broke my Ambikas optrex display somehow aswell. It’s a bad day to solder.
What was that chinese lcd sellers name again? The red one’s looking good and now I need replacement for my optrex.

It’s getting frustrating. Any clue why my 644p has the signature of a 328p? And why all fuses are fixed on 0x00? No chance of changing them, I tried several -B.

I had some weird problems like that earlier on my Mac, changing the USB hub to which the avrispmkII was connected seems to have fixed it.

Are you trying to program a blank chip?

Yes, blank one. Just as I was gonna give up, I added a cap between the programmers’ reset and ground because everything looked like reset was doing funny things. Worked. More or less…still not programming quite right but at least i could set the lfuse… now how do I set the others :x

Lfuse only works with external power and apparently lock works too. hfuse - nope. And it’s still thinking that it’s a 328p. Or sometimes 0xffffff. Kinda moody.

I once had a similar behavior (on a different project) where I would not be able to flash the chip, and it would show as a different type of processor. The reason was that one of the capacitors at the xtal was shorting it to ground. Maybe it’s worth checking that again.

I flashed it now. Funny story: no reset on the Midialf ISP header…but a bunch of other crap noone needs.

Solved it, short on one of the arduino headers