[SOLVED] Shruthi pots not working?

I have finally built my Shruthi, apparently everyting is ok, 90%
I have successfully built the firmware and apparently it uploads with no errors, using a usbasp programmer
Seems to be mostrly working (MIDI in is OK; I can change presets and play with it)
But when I turn the pots like Cutoff or Resonance, the value on screen change, but there’s apparently no change in sound…and then the value reverts to the original value (128)
or, another example, I set attack to 0 decay to 0 and so on, nothing changes in soud and then sthe atk-dec-sus-rel showas all values at 128…

firmware issue or hardware issue?

1 Like

SOLVED:
it was a firmware issue, or better, an issue with the AVR Toolchain on my Mac

I had downloaded CrossPak on Mac, but didn’t pay attention to the notice “Make sure your avr-gcc is as close as possible to 4.3.3”…

The latest version of avr-gcc included in CrossPack doesn’t seem to work.
I have tried installing almost all previous versions of CrossPack (some complained when making, some not) until I found the corrrect one.

BTW the one I used is the “CrossPack-AVR-20100115.dmg”

Now everything seems to work correctly, all pots change their paramters and the values are retained…