[SOLVED] IR3109 filter no audio out

SOLVED! All the legs on the old IR3109 weren’t making reliable contact into the socket (maybe they made them thinner back then?) – I put some flux on the legs then dabbed on a bit of solder to make them thicker, then jammed it into the socket. Works great now!


Just finished building IR3109 filter and I can’t get any sound out at all (yes I jumped R1 and R2). The control board is fine, works great with other filters. IR3109 is from Ebay, advertised as verified to be working. I have -5V at VEE and +5V at VCC on pins 8 and 16. I selected lpf as the filter type and also tried all other filter types and scrolled through all the presets. No sound whatsoever.

What else should I check to verify that this is a working IR3109 chip?

This is the 4th filter I’ve built and I’ve yet to have any issue with audio output. I even tried it with 2 different control boards. I suspect the IR3109 isn’t actually working but I have no idea how to test it.

Here are some basic DC measurements for pins that seemed to have supply voltage or zero voltage or something that seemed to change based on manipulating filter parameters on the control unit.

PIN 1 GND: 0 mV
PIN 2 : 0 mV
PIN 7: +5V
PIN 8: -5V
PIN 9: Changes from about -77 to +110 mV when I manipulate Filter Cutoff
PIN 16: +5V

Voltages on other pins did not change when I played notes or tweaked filter controls. I’m just taking guesses here… I have no idea what should actually happen with a working IR3109.