Shurthi XT assembly questions

I finally am building an XT that i got what now feels like AGES ago, and i have some questions that i could not find answers in the “archive” and diy resources for building.

XT control board and filter board are connected with those “stackable” headers ? I got my boards from laurentide synthworks, and i know ( im away from them atm ) it was confusing to me as to how i get them “stacked”, aka mounting holes were not aligned. BUT i could be totally wrong, this is something that im thingking about and im not sure. For the setup anyway i will have to resort to using those arduino dupont cables, as i already soldered trim resistors that have their trim screw on top, noticed that way too late.

Do people leave avr isp slots “empty” or should i solder something there ( i do plan to use it to burn the eeprom myself, i have never done anything similar, but i want to try ) and if what, so to prevent accidental shorts after.

EDIT: I am way too tired, have to rest more often, as i just saw this instructions on xt case assembly

Does anyone have any ideas which power switch should fit? I already messed up two times from reichelt catalog, and have to search for power slot, audio jacks and switch :slight_smile:

I’ve never built the Shruthi XT, but have built the regular Shruthi. The stackable headers connect the two boards. The boards will also be held in place by the case. I did have to trim the stackable header pins. I originally connected two boards with Dupont cables too, when I used the trimmers for the screen and tuning the filters. I left the avr pins empty, you can always solder them in when you need them. Good luck with the rest of your build.

Im not going to open a new thread, but is this supposed to sit like this or i got the wrong audio jacks ( again )

Wrong jacks.

I used these jacks for the filter board.

I wish Reichelt had them, i ordered something else from Mouser.de, order was around 20 eur, they shipped from USA and i paid on top of that 25 eur import tax. Everything else i tried from reichelt, but they are either wrong type like in the picture, or narrow body so they dont fit. I think i finally found out those exact at some audio store after googling, but im waiting to get them to actually say yea finally

While i am waiting for jacks, i thought i give it a try to program the atmel onboard using avrdude, and this handy thing Diamex AVR usb stick

And this is the result that i got, i have no idea why. I also have no idea how to really test it, to discern if it is hardware problem or firmware one. It looks like it “boots” but nothing works, and avrdude verified what was written ( tho i did not compile from source, i googled untill i downloaded a zip archive with precompiled firmwares )


I thought its better to write here than to open a new thread. Would be super gratefull if somebody encountered something similar and could offer tips as to where to look

Could it be that its my first try to program an atmel and that i just read about setting fuses now? Oh well, i cannot wait to try it out on thursday now.

Still managed to mess up with the third atmel i bought :smiley:

So i managed to get into avrdude interactive mode, and to look around and this is what i see:

>>> part

AVR Part                      : ATmega644
Chip Erase delay              : 55000 us
PAGEL                         : PD7
BS2                           : PA0
RESET disposition             : dedicated
RETRY pulse                   : SCK
Serial program mode           : yes
Parallel program mode         : yes
Timeout                       : 200
StabDelay                     : 100
CmdexeDelay                   : 25
SyncLoops                     : 32
PollIndex                     : 3
PollValue                     : 0x53
Memory Detail                 :

                                  Block Poll               Page                       Polled
  Memory Type Alias    Mode Delay Size  Indx Paged  Size   Size #Pages MinW  MaxW   ReadBack
  ----------- -------- ---- ----- ----- ---- ------ ------ ---- ------ ----- ----- ---------
  eeprom                 65    10   128    0 no       2048    8      0  9000  9000 0xff 0xff
  flash                  33     6   256    0 yes     65536  256    256  4500  4500 0xff 0xff
  lock                    0     0     0    0 no          1    1      0  9000  9000 0x00 0x00
  lfuse                   0     0     0    0 no          1    1      0  9000  9000 0x00 0x00
  hfuse                   0     0     0    0 no          1    1      0  9000  9000 0x00 0x00
  efuse                   0     0     0    0 no          1    1      0  9000  9000 0x00 0x00
  signature               0     0     0    0 no          3    1      0     0     0 0x00 0x00
  calibration             0     0     0    0 no          1    1      0     0     0 0x00 0x00

trying to read fuses gives me random? values each time i invoke a command, and panel leds also did change colors when i tried chip erase?

EDIT: I Completely removed the atmel, and it still shows top row on display as blocks !?! and random leds when i power it up. Time to desolder and check where!

The LCD displays these blocks by default, if it has not been initialized yet. Same for the LEDs Shift Register: It is initialized with a random state “by default” (as in: no default values). So that is working okay-ish, but obviously the communication between the Atmel and the LCD are not working. Either because there are non-working solder joints somewhere, or because the firmware on the Atmel is not correctly flashed.

I don’t think your microcontrollers in themselves where broken, but it is more likely that the firmware is not working. Compiling it from scratch resulted in a weird firmware for me because I didn’t have the right compiler versions. But as you wrote, you are using precompiled firmware, which is good! Are there still the precompiled firmware versions in the Mutable Instruments Archive?

1 Like

I have not found it in the archives, or in the github ( in compiled form ) but i got a zip file from here, and there were two links to compiled ( aka .hex ) versions of firmware. I also found a 7zip archive containing latest firmware, muboot and first 16 patches, along with a plethora of windows tools ( which i dont use, im using linux ).

From most of the hex files i tried to upload - i got an error about something wrong at around line 100 or something, i cannot remember now exactly.

In advdude interactive mode i know i had gotten errors when trying to set fuses there, and using the read fuse(efuse,lfuse,hfuse) gives me a random value each time i invoke the command - eg read hfuse… it could also be a programmer thing.

Bleh, i managed to unsolder a couple of vias when unsoldering the lcd, and also ripped out a small copper path, i guess i got over with too much heat.

What happends when it looks like a piece of solder is never going to melt ? Cause that was what was giving me trouble, get it to become liquid again so the wick can do its job.

Ah well, im waiting for the new pcb to arrive :expressionless:

Usually that’s when this pin is connected to ground, so the entire ground plane absorbs the heat. You can try adding some solder to liquefy the whole joint.

Guess i overheated the whole ground plane, some “streets” also came off. Since my last build it was years ago, i havent touched the soldering iron for such fine work in some 8 yrs.

I guess it was due time to order a proper soldering iron, some better solder vacuum and more wick!