Shruti-1: Partially works, but no MIDI, Audio out?

Ah, I’m so close! I’ve had a number of distractions over the past month, and I finally had a few hours to sit down with my Shruti-1 kit tonight to troubleshoot it. Let me start by explaining what does and doesn’t work. When I switch it on, I get a display, but no backlight. On the display, I can see the Shruti-1 boots up. All buttons, digital pots, LEDs all seem to work fine. Sadly, when I send a MIDI signal from my controller (all channels, all devices - tested it with other synths and there’s definitely a signal on ALL going out), the Shruti does not display that it’s receiving a signal. Therefore, I get no audio.

Now, to make things more interesting, when I first started troubleshooting, at first, I did receive a MIDI signal (I saw the little midi icon show up) and the display backlight did show. I’m afraid I might have shorted something somewhere along the building/testing phase. However, I have never been able to hear any audio.

I checked ALL the test points in the instructions and they all check out to be ok within +/- 0.1v of the specified range.

Here is what it looks like:
The Shruti Mainboard

Another shot of The Shruti Mainboard

The whole Shruti kit

Have you checked that you get audio when you trigger the test note (2s press on 4th button)?

A couple of things to check:

  • no short between GND and +5V. With the power off, check the resistance between GND and +5V (should read at least a hundred).
  • continuity between the GND and +5V rails and the display.
  • with all IC in place, and the LCD and controller board connected, try reading the voltage at one of the +5V points.

Hi Pichenettes,
Thanks so much for responding.

I tried the test-note, no audio. When the test-note is triggered, does the display show a note trigger (like a MIDI note)?

  • I tested the signal with the power off, using the hack-me header, the reading is ~150ish.
  • I tested the display rails, with the power on, it shows ~4.9V. Off, it shows ~160ish.
  • With the power on, the voltage at the +5V is at ~4.9V at any of the test points show in the ‘testing’ step of the instructions, seems normal.

Any other ideas? I feel like I’m close and chances are, I did something dumb!

Triggering the test note doesn’t show the “note on” icon, but there’s a blinking LED counting beats. Your readings look normal.

There seems to be 3 unrelated problems:

  • No backlight on the LCD. This could be due to a short on the LCD PCB (it happens to me once… a little piece of metal/solder stuck between some of the components on the LCD board), to a weak input voltage/current, to a bad polarity (eg TX and +5V swapped).
  • The “no audio” problem can happen at different places in the chain - but without a scope it’s hard to identify where the signal path is broken.
  • The “no midi” problem might be a cause of something else, since you said it worked for some time.

Yeah, I completely agree with all your points.

  • I just ordered a new LCD/PCB from Sparkfun: http://www.sparkfun.com/commerce/product_info.php?products_id=9395 to see if that’s the issue.
  • Hmm - not sure how i’d test that. Any other tests I can run within the signal chain?
  • The MIDI issue is interesting, since that was working before. I used the CNY17-1 optocoupler with a socket… Any knowledge on what the V reading should be with those 6 pins?

Thanks again for your help!

Unfortunately, with a simple meter, there’s not much you can troubleshoot besides the power rails of the IC and the continuity between points.

Regarding the signal chain, a first thing you can try is to bypass the CEM3379… See if you can hear the test tone with the CEM3379 bypassed:

If you have a spare audio connector (or wire you can wrap around an audio jack, or any other way of getting a signal into an amp/soundcard from a pair of wires), you can try hooking up the sleeve of the connector to one of the ground points (eg GND on the hackme connector), and the tip to:

  • The right pin of R10 (Just before the “S” of “Synth board”). If you get a signal here, the digital oscillators are running correctly on the AVR’s side.
  • The top pin of R13. If you get a signal here, the input mixer is also running fine.
  • The bottom pin of R12 (The one near the A in “A100k”). If you get a signal here, the CEM3379 is running fine.
  • The bottom pin of R25. If you get a signal here, the final amp stage is running fine, and the culprit is a bad solder point at the audio output.

It seems that I have the same kind of issue here.
Bypassing the CEM3379, signal is fine (hey, I can here some Shruti sound, \\o/!) from R10 to R13.
I lost it at the R12.

The weird thing is coming when I test without bypassing it, the CEM in his place.
I get signal at R10, R13 and R12. It desapear only at R25.

@nightkybuild:

and what’s going on at the right pin of R23? Have you soldered a pot or not? See if you can get something at the right pin of R23 with the CEM in by messing with the pot (shorting it, possibly). If so, the culprit is a bad solder point/short in the R24/R25 area, or possibly a problem with the op-amp itself.

in the bypass case… there should be continuity between the bottom pin of R12 and bottom pin of R13 when the bypass is on.

Okay! Almost a MONTH later, I’m finally back from some time off… really want to get this thing working!

So I got my new SparkFun LCD, hooked it up, booted the Shruti and the new LCD works great! So that’s one problem solved. I still get no audio and have managed to discover a very odd trait. Now, when I boot the Shruti, it boots up fine and then I see this: http://flic.kr/p/8oapkz

I’m worried the main processor is fried, because I’ve checked all the voltages - they check out ok, but for some reason, the Shruti just displays this weird “cutoff: value” and goes wonky. I am not touching any pots or controls when it does this. Furthermore, when I used to hit that “test note” fourth button, the yellow light would show activity, now - nothing. :frowning:

Any thoughts? Thanks again for your input… I am a bit discouraged at this point, but I also feel like I’m close!

Hi,

Doesn’t look like a bad cpu problem. It could be a loose connection/solder point on the cable connecting the two boards, or something wrong on the synth board side which pours noise into the ground.

Can you still navigate between the different pages?

Hi,
I thought this might’ve been the case too, so I unplugged the control board and booted the shruti… same exact issue.

This sounds silly, but when the unit is on, if I poke my finger around the back, the unit seems to go freaky when I touch around the quartz/middle-left of the cpu. I thought the culprit might’ve been a bad soldering joint around there, but everything looks fine. Any thoughts on things/voltages I can test in that area? The voltages listed for the CPU socket check out just fine.

When the control board is unplugged, the ADC pin is floating so random voltages are read for all pots, so you obviously get “flickering” readings for all parameters. No problem here.

There seems to be two problems - one with the control board or the connection to the main board (indeed, along the path from the pots to the ADC input) ; and one with the audio output - anything that could explain the “no sound” issue. Do you have access to a scope?

Yes, you’re absolutely correct - two issues - no audio and the weird data flickering issue.

I’ve been focusing on just getting the data control / display stable, and then I’ll work on the no-audio issue. I spent hours this morning cleaning all my joints up - the joints all look much cleaner, much better. I plugged it all in and still got the weird data flickering issue. I started poking around a bit and noticed that if I touch the top of the capacitors, the Shruti appears to be stable. Does this mean the capacitors are blown or there is something wrong with them?

Imgur

Thanks again for your input and continual patience and wisdom. :slight_smile:

Hmmm… Now that I see the video… I got this problem on one of the protos – don’t know what it was due to, but it went away with a jack inserted in the audio out.

In a way, it’s encouraging to hear that you’ve seen this issue before. :slight_smile:

I am wondering if replacing those five capacitors might do the trick?

Also, I don’t currently own a scope. Going to look in to renting one, possibly.

Capacitors don’t usually go bad like that… What causes the problem with the flickr pots is either a bad connection for the >ANL line, either an unstable 5V rail on the control board, or some noise/crap poured into the ground, something which might be caused by whatever prevents the audio out to work.

If you are really that despaired and are ready to pay the shipping fees back and forth, you can send me your board for me to have a look.

Okay, it works now!
The dual op-amp AD823 was simply dead actually…

Yep! Mine works now too! http://www.flickr.com/photos/nokapixel/4976320524/

Very excited. Thanks for the help. :slight_smile:

Hi there,I’m exactly in the thread title situation!
My problem is the MIDI IN![](it’s the only problem,display and its navigation are ok,audio out is ok,both sequence and audio presets work fine,all pots and switch are ok.I don’t kwnow where to check midi in soldering joints.
thanks for your attention)