Shruthi issue(s)


#1

So I bought a used shruthi XT recently and tried to load it with YAM - booting it while holding S6 gives no result. Seems like this means there’s no bootloader installed.

Could anyone point me to some kind of guide on how to resolve this? I’m reasonably technical but don’t own a soldering iron. Alternatively if there’s someone I could send the chip to and have them do it for a small fee, that could also be an option. I’m in the UK.

Thank you!


#2

If there’s no bootloader you’ll need to program the microcontroller.

If you don’t have the resources for this PM me - I’m UK based.


#3

The easiest way would be for you to ship the microcontroller to me to program. Without the hardware programmer or programming software you’ll have major problems!

In terms of cost it will be the price of postage back to you, but if you wanted to make a small donation…I am a poor pensioner after all!:nerd_face:


#4

Heya, that sounds great, thanks for offering to do this! I sent you a PM, we can sort out details there if you like. Cheers


#5

There’s another problem with this unit - it doesn’t respond to 4 notes per octave. The note icon lights up but no sound is produced. Tried with 2 different sequencers that are known working.

I’d do a factory reset but it appears you need a bootloader for that. Have I missed something in the settings?


#6

Yes, rag changes the tuning/scale (and some scales don’t have notes for all keys).


#7

Fixed, thank you!