Shruthi freeze

Shruthi freezes when sending and receiving MIDI data!
if i play a note or play a sequence from ableton!
where should I start looking? or someone has a clue what it could be?

Which board version?

Which firmware version?

Does it happen all the time?

Computer connected to MIDI in or to both MIDI in and MIDI out?

Wich midi interface?

Firmware 0.92 and the board is v0.7
yes it happens all the time! and both Midi are connected!
Midi Interace is AMT8
one other shruthi works great no problem the same controlboard and firmware only other filter

When both the MIDI in and out of the Shruthi are connected to a computer, it is very likely that MIDI feedback loops will occur. The Shruthi sends a note to the computer, the computer sends it back to the Shruthi and the Shruthi ends up spending all its CPU cycles decoding MIDI rather than responding to buttons or generating sounds.

Try unplugging one MIDI cable and see if this solves the problem. Also, try changing the MIDI out mode in the system settings page. The only mode designed to work with both in/out connected to an active device is “ctrl”.

oke thank you i think i got it! I am ashamed :slight_smile:

/edit: Olivier already mentioned the “ctrl” mode.

I still have the problem! whether midi “off” or “ctrl”! it freezes??
I have no clue what it could be? only the MIDI IN ist connected.

Does it happen every time a MIDI message is sent? Or randomly after minutes/hours of use?

I just try it out when the problem occurs! appears always different! ??
edit yes by sending midi data

Ok, mine is starting to act up in the same way. V0.7 board, midi set to ctrl, when sending it midi it will freeze after several minutes requiring a hard restart. Tried different power supplies, same result.

Latest Firmware.

This seems to be most prevalent when tweaking controls while receiving midi data, I am testing now with a latched arp and I cannot get it to freeze…

Any particular MIDI message that triggers the problem or just note on/off? Also, can you reproduce the problem with an older version of the firmware?

just on/off notes. I can do it from a sequencer or keyboard. Could this be a boot loader issue? IIRC Dalkiel also DIY’ed his avr… I’ll try older FW later today but I believe it was also doing before I updated to the current one and I just dismissed it as a bad connection since I had it torn apart at the time, but now that I have had a more objective look at it, something is definitively hanging it up from midi, not the engine since when in the latched arp mode i can go crazy with the controls without issue

I don’t think it’s a bootloader issue. Once the Shruthi-1 is started, the bootloader won’t have any influence. During development I work all the time with a unit that doesn’t have a bootloader and it works fine. I don’t think it’s a software problem either - it could have been if more exotic MIDI messages had been sent.

This looks similar to a problem I observed on three v0.5 board - the sharp edges on the MIDI signal appeared to cause the problem - within minutes of play or almost instantly when sending heavy MIDI traffic (for example by playing like crazy with the modwheel and pitch bender). The problem disappeared when I slowed down the edges of the MIDI signal (since v0.7 the choice of pull-up resistor for the opto is such that the MIDI signal is less sharp). 6N138 + 220 ; or 6N137 + 22k will slow down the signal while keeping it sharp enough for decoding.

Ok, I probably have the older parts in since I am pretty sure I have the first rev board actually… Will change and report back…

If you have a version 0.5 board and use a 1k resistor as a pull-up, the most immediate fix is to swap in a 6N138. 6N138 + 1k is slow but works with most MIDI sources.

6N137 and 22K looks like its doing the trick. Thanks!

Which value was there before? 1k?

yes, Me thinks I got that board on the very first run so it was based on the old BOM… (recall the fun we had flashing the AVR with the wrong bootloader :P)

Unfortunately I am running into this issue with the classic programmer I just built using v0.8 control board. Unit will be fine sometimes for quite a wshile then randomly crash requiring hard reboot. Using the 10k pull up with a 6n137. After all these years and finally getting it running it’s a bummer to have it crashing from midi messages.