Shruthi Build w/ DSP Board Troubleshooting

A couple years back or so, I failed terribly at a Shruthi build. :slight_smile: I’ve learned so much since. And my current attempt is considerably more functional.

But I’m encountering several issues and was hoping someone could provide some suggestions as to where things might be failing. I’ve traced pretty much everything from each mcu to it’s outputs, but I’m missing something.

  1. When navigating the menus, the display occasionally gets “garbled”. Incorrect letters appear, sometimes there are symbols where there should be letters. I suspect I just need to double check the solder points for the LCD, but if there’s anything else I should check, let me know.
  2. Every time a midi note comes in I get the ! symbol instead of the note symbol.
  3. Possibly related, settings don’t appear to save. I can go in and set the filter to dsp and if I hit save, I get the “save midi/keyboard settings” prompt and select OK. But if I leave and return to the filter settings page, sometimes it still says dsp and sometimes it’s reset to lpf. (Interestingly, I tested renaming and saving a patch, and that worked and is retained fine.)
  4. I get the issue where on the DSP board, only the red LED blinks. Next on my list is to check everything in the TX path, but again, if there’s something else I might be missing, some suggestions would be great.
  5. No sound, which is kind of a given, considering issue 4.

So that’s basically it. Everything is pretty much almost working, and I’m just having trouble tracking down where I’ve gone wrong (or if I might just have a bad part somewhere).

This looks like a problem with the MCU on the digital board - maybe it’s defective or it has not been programmed correctly.

Thanks!

Yeah, that’s about what I was starting to think. Already have another 644p on the way.

Hopefully the new chip does the trick.

Update: got impatient and rather than waiting for the part managed to reset the fuses to default, erase the chip, and start over. And now it all appears to be working fine!

Parts of this sound like the same problems i had. My display was also flickering and i did not had any sound coming out at first. For me it was pretty easy to solve. Have you checked that you have the right filterboard selected? And the right version of the software running? Have a look on this one: Shruti1/Phoenix from Tube Ohm problems [solved] if not allready done :slight_smile: But i think i did not had any issues with saving, so i guess this could be really something wrong with software/MCU. Good Luck

It definitely ended up being just a problem with the MCU. Sorted that out and everything was fine. :slight_smile: