Shruthi Bootloader Problem


after a few firmware flashing days i come to the end that ONLY ! the YAM Software works right on my Shruthi XT Device. I want to upload the Bootloader then flash the Orginal firmware via Midi. I endless tried to upload the muboot.hex to my Shruthi. But i can not start it in Bootloader Mode. I use AVR Studio to flash the Bootloader with fuses:
extendet Fuse: 0xFD
high Fuse: 0xD6
low Fuse: 0xFF
lock Bits: 0x2F

can anyone help ?



Does your Shruthi boot with the splash screen or straight into the filter menu?

Try the method outlined here, worked fine for me.

I use avrdude with usbasp to program the Shruthis I build.
Here is the sequence I use and never had a problem.

avrdude -B 100 -V -p m644p -c usbasp -P usb -e -U lock:w:0x3F:m -e -u -U efuse:w:0xFD:m -U hfuse:w:0xD6:m -U lfuse:w:0xFF:m -U lock:w:0x0f:m

avrdude -B 1 -V -p m644p -c usbasp -P usb \ -U flash:w:shruthi1_1.02.hex:i -U flash:w:muboot.hex:i -U lock:w:0x2f:m

avrdude -V -p m644p -c usbasp -P usb -U eeprom:w:internal_eeprom.hex:i

Hope it helps.

1 Like

If I remember correctly, the button combo to start the bootloader is different on Shruthi XTs. Maybe that’s why it seems like flashing the bootloader doesn’t work.

Thats the answer ;))) ohh Thank you