Shruthi 1 Yellow Magic wont load patches via SysEx in S6 power on mode

I just got one built. It came with no patches installed so I tried many way to do it my self. S6 power on to go in to SysEx update mode. I send varios patches and factory ones via midi but no luck. As soon as I send Sysex via midi the Shruthi power off automatically. I have to reboot power to make it turn back on. No patches are installed. Just empty. I have a feeling there is something wrong with the bootloader. Firmware version is 1.2.

Any help would be appreciated. THank you.

I tried doing it via C6 and SyEx Librarian 2 on a Mac with 15 and 250 delay settings.

I just did a Firmware upgrade again. It loads firmware fine. No issues here. As soon as I send patches to it it just shuts off instantly.

I guess in SysEx update mode the Shruthi expects an OS update, and not patch data. Try sending in “normal” mode, maybe that already does the trick?

Indeed. The firmware update mode is, well, for firmware updates…

It would be very silly if you had to switch off the synth off and on every time you want to try a patch…

Just did. Does nothing.

Oh I understand. So is there a way to load factory patches to shruthi?

Power it on normally and send this file

Ok I figured it out. The patches got put in to random places. I guess I should use a MIDI librarian to arrange them. Thank you very much for clearing up firmware and patch update. All working:)

Try slowing down the transmission speed. It looks like the Shruthi is still waiting for a save operation to complete while your SysEx app is sending the next packet - and thus this leaves gaps between patches.

Got it. That worked. Thank you.