Shruthi 1 Smr4 MkII Power Supply Issue (Solved)

Having trouble getting my power supply on the Smr4 MK II to function properly. I attach the black Com probe of my multimeter to the Blue point and the red probe to the red points and it gives me the correct 5 volt reading. But when I attach the Black Com probe of my multimeter to the blue point and the red probe to the green points it gives me a reading of zero volts instead of -5. I’ve checked many times and all the components seem to be in the right spots with the right polarities. I’ve also re-soldered joints that looked a tiny bit dodgy but the problem is still there. Does anyone have any idea what the problem could be or how I could trouble shoot to find the problem? I tried to desolder electrolytic capacitor C20 cause it was crooked, and it got quite hot. Could that be the problem?

Any help anyone could give me would be really appreciated.

it could be the problem. anyway there seems to be a short of some kind between -V and GND. if you’re not sure about the cap desolder it and check continuity between -V and GND points (with no power plugged in!)

  • Verify that there is no short between the GND and -5V rail (unplug the board, set the meter to continuity testing mode and check that it does not beep when the probes are on a blue point / green point).
  • If there is no short between the GND and -5V rail, try measuring the voltage on each pin of the 7905 regulator.

Thanks for the replies. There are no beebs when I do the coutinuity test you told me to do. However when I attach the black probe to GND and the red probe to the pins of 7905 I get the readings =

  • = 0 volts

O = 0 volts

I = seems to fluctuate. and it was geting 1.1 volts the first time I tested it , other times different readings, Now 0 volts. I can’t get the meter in properly from the top for the middle pin so the readings for I are from the bottom. /: + and O are getting 0 volts from the bottom and the top.

Really appreciate your help.

Does the LT1054 get very hot? Is it correctly inserted? Maybe you have mixed it up with the TL072?

You mean the Dip 8 socket? There are two for the filter board, I thought they were both the same? I haven’t added the IC LT 1054.

Thanks again for your help.

Oh I missed the line that say put in the IC. LOL Feel like a totes idiot. Been agonizing over it for 2 days. Sorry to Waste your time. Thanks for your help. lol hope I haven’t damaged any thing else.

Yep, all the voltages read fine.