Shruthi-1 - firmware update stuck. need help!

hi guys,

just tried to update the firmware (orig. .097) to the latest firmware, following the steps described here in the forum using the C6 tool. During the update LED 1 is blinking, then LED2, then LED3, then LED4, then the data is complete send and LED 1-3 remain lid. thats it. tried different MIDI cable and MIDI interfaces. same problem. need help please!

Have you adjusted the speed in C6?

nope…?
where would i set the speed in C6?

edit:
it worked with the MIOS Studio 2 sys tool, send delay set to 1000.
after turning on my shruthi, the display was freaking out. saying something like “bed jam” or something. the LED and display was like on LSD. I think i might read it here somewhere. i turned it on again my holding down the push encoder and everything was good.

What was that disco light?

edit:
the disco fever happened again :frowning:

Holding the encoder while powering up the synth changes the hardware mode to Shruthi XT, FCD72 programmer or standart 4 knob shruthi. This is new in firmware 1.0x

The disco is the shruthi set to the wrong hardware.

thanks @shiftr for clarifying!