Shruthi-1 Filter Breadboard CEM3378 issues

hi,

Maybe someone can help me. I have built my own CEM3378 breadboard and oriented myself to the following schematic (with adaption to CEM3378):

https://github.com/pichenettes/shruthi-1/blob/cc_remap/shruthi/hardware_design/pcb/Shruthi-Analog-CEM3379-v05.brd

https://github.com/pichenettes/shruthi-1/blob/cc_remap/shruthi/hardware_design/pcb/Shruthi-Analog-CEM3379-v05.sch

Of course, I took note of the few changes to the Cem3378 pinout: http://www.buchty.net/ensoniq/files/cem3379.pdf (Page 2 CEM3378)

In this case, I would like to additionally lead two external audio inputs to the CEM3378. which I get through Ch A Input (Audio EX2) and Ch B Input (OSC + Audio EX1 by TL072)

The GAIN is controlled identically by VCA out of mainboard and I solve the PAN of two inputs with CV1 (with the “circuit” as described here: Shruthi "CV" outs & Koma Field Kit)
I also saw that everything was soldered correctly so far. Now I have the following case:

  1. there is no sound. when I measure myself with an oscilloscope, I only measure in the mV range of noise. I also don’t hear any resonance sound (when “res” is turned up). But GAIN has voltage (also on the CEM chip) and I can also measure +5.02 and -5.02 on the TL072 and CEM3378. R2 - is turned down - so signal should pass.

  2. the 7805 gets really hot, after a while. Is that normal? the smr4-mkII board, on the other hand, is quite warm due to the LCD but not so hot! the 7805 is also hot without TL072- and CEM-chips in it. In any case, hotter than operated by the SMR4-MKII board. But it least it only gets hot when the mainboard (with LCD) is connected (the LCD brightness is set quite high).

  3. Pin 2 of the CEM3378 IC always has -5V on it, no matter what I set on the 5k trimpot or 20k trimpot. That should change it or not?

I first took out TL072 and CEM chip. I have an oscilloscope and multimeter at hand and packed a cable between the filterboard and the mainboard so that I can get to everything easily. Which points could I test directly (with multimeter or oscilloscope) to further narrow down the error?

Thanks a lot!

Greetings,
rio

Does somebody still have an idea?

I strictly followed Shruthi-Analog-CEM3379-v05, with the exception of the pin assignment of CEM3379, which was adapted to the CEM3378. So far I have not been able to find any short circuits - I went through everything several times. But what makes me wonder is the higher heat on the 7805 than on the smr4-mk2 board, as well as the unchanged voltage (-5V) on pin2 (Freq.).

Is there any clue as to what should be checked or what could be the cause?

Edit: Can it be that i have the freq/res trimpots connected in the wrong way - pinout 1-2-3?:


vs

i use the 64Z-5.0K, 64Z-20K

Greetings, rio

ok i rewired the trimpots and i had fixed a forgotten bridge. everything works now, but why does the 7805 get so hot in the long run anyway? normal?

Linear regulators can get really hot. All the power they have to get rid of to bring their input voltage down to the regulated output voltage is directly converted to heat. As long as you can still touch it without burning your fingers, it should be okay.

If it gets hotter than that, maybe you could measure the current at the power input an post that here. Then we can see if there is a problem.

A sidenote: Longevity of electronic parts is directly related to their operating temperature, so if you can, attach a small heatsink to the 7805 to keep it cooler.

Thx for explanation.

So if after a while I hold my fingers on the iron, it hurts. But I can still touch briefly. I am not sure if that is justifiable.

I am only surprised because the same mainboard with the smr4-mk2 board the 7805 stays cooler. as if the 7805 on the smr4mk2 board can handle it better (and the heat on 7805 of the 3378 Filterboard comes without TL072 and without CEM plugged too).

What could be the reason for the temperature difference between the two filter boards? the power supply is the same …

You probably made a mistake in your circuit that causes it to consume a lot of current. Which mistake? I don’t know, please post schematics!

I strictly followed the CEM3379 board 0.5 and modified it slightly for the CEM3378

note:
J6 is the 2nd audio In.
J7 is CV2 external Out.

The devil is in the “modified it slightly” :slight_smile:

And do you see anything significant at first glance? For me it still looks ok.

the pcb looks ok so far, but what struck me:

I am not sure whether the v / oct trimmer and loww trimmer react correctly. It changes, but the effect of turning the trimpots seems too weak to me. if I remove both ICs (TL072 and 3378) and then I measure the voltage at pin2 (3378 socket) and set the CUTOFF in the software from 0 to 127, I get a voltage between 0.0V to -0.11V. normal? the voltage -0.11 does not change when I change the trimpots. is that normal too? I am confused - how should the voltage normally behave on pin2?

it’s a little strange. after a few measurements, without TL072 and CEM3378 stuffed, I tried to measure the voltage at pin2 and GND with the multimeter. sometimes it is between 0.0V … -0.13V (by turning CUTOFF up and down) other times (e.g. when I switch the voltage range back and forth on the multimeter) then it also shows me values between -5.5V … -3.0V (respective to the CUTOFF value). Then while doing this it sometimes didn‘t change voltage values on multimeter. And generally the change of values is shown to me on the multimeter with a very delay.

So my question - Is it not possible to correctly measure the voltage with the multimeter, or is there something wrong with the circuit? - I just don’t see what. What could I do to get to the bottom of this? The 7805 gets warm to hot during this time - but only if the mainboard is connected.

That sounds to me as if your multimeter might be a bit weird. Before you go on, you should fix the tools, otherwise you’ll spend forever debugging this. Seriously, you need to be able to trust the measurements.

That is to be expected, one of the main power sinks is the display backlight that runs off the 5V rail. I wouldn’t go crazy about the warm 7805. Add a small heatsink and it’ll probably be fine.

… but on the other hand, the multimeter can measure the voltage -5.02V and + 5.01V at the IC power pins in a totally stable manner. only pin2 of IC3378 acts weird (I’m measuring with DC setting - is that correct? both voltage (+ and -) have an influence there).

Edit: I have now changed the both 3.3uF electrolytic capacitor of the ICs and soldered the connection to the 20K trimpot again - the result is identical.

Edit2: I have now changed the 7805CT with LM340T5 7805 P+. I can still touch it after a while - it doesn’t get that hot.

… that should fit so far. I think the CEM pin2 issues are due to my multimeter. Thanks!