Shruthi 1 does not power up [SOLVED]

Hi guys,

short intro first: I am a big noob in terms of knowing and understanding what I am doing when it comes to electronics. This is my third DIY project, after two Bleep Labs’ successfully built and since I felt my soldering skills were good enough I decided to start building my Shruthi 1.

Now, unfortunately, I didn’t have a multimeter with me when I started and got to step 5 in building the SMR4mkII filter. Now, please, don’t beat me up for this, I proceeded after that point despite having some issues getting the DC connector in place. Nothing I couldn’t fix removing some solder with a ribbon and resoldering. It is true that the joint looked awkward after resoldering.

Instead of checking I kept building 'til the point I am to test the digital board. When plugging my adapter I won’t see the LEDs lightening up.

I have my multimeter now, but first stupid question would be: can I do the checking on the back side of the filter board since everything is already soldered? What joints should I check?

Could someone help troubleshooting and be forgiving with my newbieness?

Yes you can still do the voltages test with everything soldered on the smr4 board… Also on the front side.
Did you solder the jumper wire near the DC connector?

Is Q3 reversed? And i can’t see the Orientation of the LT1054….

Thanks for the quick answers!

I do have the jumper soldered so I put the COM of the tester on GND on the back side. Where should I put the red probe to tell you relevant data?

Let tell you some more info, just in case. if I put the red probe on the green spot on the back of TL072P (as marked on the board) I get -5.2. On the red spot I get -0.6…

@fcd72. Q2 and Q3 are ok I think. The LT1054 is placed with the dot facing the opposite side of the others and so is the notch of the socket.

Btw, my first idea was that no power was getting into the board whatsoever (I thought I might have damaged the DC connector desoldering and resoldering). The fact that I am getting voltages on my tester proves this wrong?

Oh on the mobile site i didn’t see you had the picture there i see the jumpers now.

There sure is power on your board. Does the 7805 get hot? Can you measure the voltages on the 3 legs of the 7805?

And a picture of the backside of the board maybe…

I don’t have the impression of the 7805 getting hot. The voltage of the legs is:

Left (closest to the end of the board): 11.24
C: 0
R: -0.62

I attached the pic of the backside of the board.

From your first post it seems the problem might be on the control board, not on the filter board, as no LEDs light up … could you show images of the control board (both sides) ?

Hi eelco, thanks for joining!

I attached them.

Your problem is first at you filterboard! You are not getting +5V because i think your 7805 is broken.
I think you need to take it out. Then you should measure the resistance between +5 and GRN to confirm there is no short. A short could be the cause of your 7805 being broken.
The control board works on the +5V from the filter board so it’s normal it doesn’t show any life with no voltage to feed.
Also please cut all the leads on the back of your board. That could very well be a cause for a short and fry you 7805.
And your power adapter is outputting a bit high voltage for the shruthi. You better use one that has a voltage of 7.5V or 9V. But that’s probably not the cause of your problem now.

Thanks shiftr!

I noticed something! LM7905 and LM7805 are not in the correct place (LM7905 in LM7805’s place and viceversa). I will remove them and solder them where they belong.

I hope this didn’t damage anything…

Oh ok this explains a lot! But I find it very strange that you did measure - 5v
Just change them around you will probably be OK.
Check some desoldering videos on YouTube if you haven’t done this before

Will do. Cheers! I’ll do it later and let you know. If it works I buy you a beer :wink:

Id recommend using new 7805/7905s they might have been damaged….

The 7805/7905 swap clearly explains a lot.

Best to cut their legs off (close to the package itself), to simplify desoldering. As fcd72 said: best replace them with new ones, as they are cheap anyway.

Thanks for the advice, guys!

I put new 7805/7905 in correct place and the LEDs of the control board still won’t light up.

I put voltages:

7805
Left (closest to the end of the board): 8.2
C: 0
R: 4.98

7905
Left (closest to the end of the board): 0
C: -7.72
R: -5.08

Your measurements looking good now. First problem solved. Now the next…

IC2 is the wrong way up!

Thank you cj55! LED 8 turned up!

I’m getting DB error on instructions now, but if I recall correctly two LEDs should turn up at this testing step. Am I correct?

It looks, as you also swapped IC2 and IC3!