Shruthi-1 - blank chip

Hi.
Sorry for noob questions and my english.
Im building shruthi and i dont have idea how to burn firmware to empty chip.
Im using win 7(64 bit) and i have STK500 v2. EDIT: I forgot that i have arduino uno board. maybe this will be easier.
How and can i burn it when chip is in solderless board?
How can i do it with avr dude - gui?
Please help me.

Did you check here
And on the wiki
?

yea i checked that, but im starting with blank chip and im little bit scared when i see this things in command line and im afraid that i fry my chip :confused:

the links shiftr pointed to are what to do if you have a blank chip. The only way you will fry it is if you feed it more than 5V.

You can download the firmware & muboot hex files and send them in through command.

EDIT: get the internal eeprom from git

This is what I do and I’ve burned a ton of Shruthi’s / Ambika’s:

  • Connect your ISP device
  • Put the hex files into the WinAVR\\bin folder
  • Open Command and change directory to WinAVR\\bin
  • Set the fuses (change "avrispmkII to whatever ISP you are using):

avrdude -B 100 -V -p m644p -c avrispmkII -P usb -e -U lock:w:0x2F:m -e -u -U efuse:w:0xFD:m -U hfuse:w:0xD6:m -U lfuse:w:0xFF:m -U lock:w:0x2f:m

  • Send the bootloader and firmware:

avrdude -B 1 -V -p m644p -c avrispmkII -P usb -U flash:w:muboot.hex:i -U flash:w:shruthi1_1.02.hex:i -U eeprom:w:internal_eeprom.hex:i -U lock:w:0x2f:m

done.

thanks but i have error:
avrdude:usbdev_open():did not find any usb device “usb”

ok solved this. Im using arduinoisp programmer something started to runinng but i get error and "timeout"
How to “name” arduino isp programmer in avr dude?

Did you enter it like this?:

avrdude -B 100 -V -p m644p -c arduinoisp -P usb -e -U lock:w:0x2F:m -e -u -U efuse:w:0xFD:m -U hfuse:w:0xD6:m -U lfuse:w:0xFF:m -U lock:w:0x2f:m

avrdude -B 1 -V -p m644p -c arduinoisp -P usb -U flash:w:muboot.hex:i -U flash:w:shruthi1_1.02.hex:i -U eeprom:w:internal_eeprom.hex:i -U lock:w:0x2f:m

Remember, you will need to make sure that the HEX files are in the WinAVR/bin folder and you change the directory in command to the WinAVR/bin folder.

My bin folder is located at: C:\\WinAVR-20100110\\bin, so in command, you should see C:\\WinAVR-20100110\\bin>

Maybe this is your issue.

“cant find programmer id “arduinoisp””

u mean what?

Did you check the link to setting up an Arduinoisp as an AVR programmer ? Or, you could get a USBtiny. Never had an issue with that.

Check in device manager for the exact name of the USB device and enter that into the command line.

I got that too under Windows. After moving the AVRisp over to my MacBook it worked straight out of the box. It seemed that there was some device binding issue with the open source USB driver that’s part of the avrdude Windows port - I did run some scanning/port enumeration tool. I probably missed something easy, but there I was and time was a wastin…

I was fairly sure the names did match up, but that’s worth checking next time.

hmm, interesting. I’m using Win7 64bit and I’ve used both USBtiny and avrispmkii without issue. When I first started flashing my own chips, I used the MIDIpal instructions to figure it all out. (scroll to the bottom). Of course you’ll need to change the fuses as listed above, but everything else is pretty much the same.