Will the source code and panel files be released as open source?

Yes and yes

Cutout of a laminated print and some small pieces of poster buddy. The pdf file is also here. I enlarged the cutouts for the holes and moved the graphics a bit to allow for this. It fit’s my mostly DIY rack very much.

Hello !
Does the module needs re-calibration when a tides to sheep or sheep to tides firmware upgrade occurred ? Thanks !


Thanks :slight_smile:

Is there anywhere to get the Sheep replacement panel still? Would love to get my hands on one if possible.

Me too!

If you keep an eye out on MW you can see them pop up FS from time to time…

Sorry to reanimating this long-dead thread, but I’m so far failing to get Sheep installed on my Tides.

It’s odd… when I play the audio file into the FM input, per the instructions in the manual, it plays all the way to the end without errors (once I’ve got the levels right- don’t seem to be able to send it from the headphone socket on my MacBook Pro, but found an audio interface that works), but the module doesn’t reboot, and the Sheep firmware appears not to be installed.

Anyone else had this issue?

Is it possible to install Sheep via the JTAG header? It doesn’t appear to be in the MI repo on GitHub (understandably, I suppose).

Sheep is in the git repo of course, in the tides directory. You need to change a #define in the code.

Ok… where?
It seems quite well hidden :wink:

Uncomment this:

I’ll try that, thanks :slight_smile:

Is the calibration process the same as for the stock firmware?

Is that all that I need to do? I tried that, and the module produces glitchy audio output (a regular crackle, with a period that seems to track oscillator frequency). Controls are laggy, and sometimes stop responding altogether.

I tried re-commenting the line you mention, and flashing the standard firmware back onto it, and it seems to run fine with that.

Hmmm I’m wondering if this might not be due to the gcc version being used to compile the Sheep firmware.

I’m using the latest MI Vagrant environment (as of a couple of months ago, anyway).

It may not be the GCC version used when you developed Tides, originally, I guess.

I’ll try again with the WAV file. Maybe there was something wrong with the bootloader and re-flashing with the stock firmware will have fixed it.

I managed to flash the Sheep firmware from the wav file, player it this time from iTunes, rather than QuickView from Finder on my Mac.

I wonder now if QuickView doesn’t play audio files right to the end, in some cases.