Schruti not working, Possible power supply problem

Finally got around to building my shruti last night
finished it off today and did the voltage checks suggested. they all were find so booted up. LCD came on fine and all buttons and knobs work and can scroll through the menus. didnt make any noise before a midi input was applied.
when midi was sent and high pitched squeal came from the speakers instead of the suggested bass sound. turned it off and looked over the circuit. one of the smoothing caps was reversed so i turned that around and tried again. this time the first midi note gave the bass sound and any following notes gave the same high pitched squealing sound.

guessing its a problem in the power suplpy. with the power off i was looking over the circuit for continuity and if i join 5v and gnd the multimeter beeps for a fraction of a second when there connected. was thinkin it might be caps discharging or is it a short circuit?
Ive looked at the circuit and both regulators are in right, chargepump is right. orientation of other caps are right. power supply being used as a 9v centre pin positive.

thinking maybe the smoothing cap got damaged during the switch around?
or maybe i might try a 9v battery instead of the wallwart PSU?

any suggestions as to what to do next??

thanks

Which one of the caps have you swapped (value?). Things to check:

  • Try to bypass the CEM3379 to check that it is not damaged. Here’s how to do it:

If you no longer hear the weird sound, the CEM3379 has been killed :frowning:

  • Use the internal “test note” (long press on 4th key) instead of the MIDI-in, try to trigger it on/off several times and see if you can reproduce the problem. Which device is sending the MIDI note? Could it be that it is sending another message (NRPN?) messing with the patch data, resulting in the glitch. Is the squealing sound dependent on the current patch/synthesis parameters?

was the 220µF cap next to the 7905, i had it the wrong way ie, neg lead in the positive hole

bypassed the filter and osc sounded clear using the test note but it did the same noise with the midi i was sequencing using renoise (i dont have a midi keyboard) . could having the cap wrong have damaged something else?

also, i only have a cheap usb->midi cable, quiet possibly the problem, although it worked for triggering and syncing midi equipment before (an electribe drum machine) mightnt work for delivering notes properly though

I don’t see what could be damaged in such a way that everything appears to work correctly for a couple of notes and then goes wrong (I was thinking of the CEM3379 being instable but this doesn’t seem to be the problem).

Can you confirm that triggering the test note several times (long press on 4th key to toggle it) doesn’t cause any problem?

I suspect invalid MIDI data triggering random notes - either at the source or at reception. Have you soldered the 4N28 or replaced it by a CNY17-1?

oh hai britters!

triggering the test note numerous times works fine
I used sockets for all IC’s on the board, dont really like soldering IC’s directly onto boards
i did use the 4N28 on my build although i do suspect its the midi source thats the problem,
either the software/driver setup or a rubbish cheap cable.Will try borrow a midi keyboard too see if that makes a difference

on googling there seems to be lots of problems with the type of usb midi cable i have
some suggested solution too though, im in college for the day so will try more stuff this evening

should i get a replacment opto anyways?

hey Ooot’s

So far, for all the people who have reported MIDI problems with the 4N28, it has always been an “all or nothing” problem - for some devices it worked, for some device there was no signal. The “weird MIDI note” is a problem I’ve never heard of before.

Have you observed that the high-pitched sound still follows the synthesis parameters? For example, if you adjust “oct” to -2, does the pitch of the note change? Is the sound killed when cutoff is moved to 0? If this is the case, it’s really likely to be a spurious “note on” message getting into the Shruti…

i dont recalll the pitch of the note changing.i do think when the cutoff was put to 0 the sound was killed.
i should be home by 8ish tonight so will double check these things and report back

would routing the midi through another midi device help?

cheers for the help!

brittney

Yes, chaining through another MIDI device could help

aaagh!

was trying to chain the schruti through another device this evening to see if i could get the midi working.
I pulled out a midi cable while it was still turned on and now its not booting properly

on turning on(with no midi plugged in) the screen says:

mutable v0.54
-1

when i try scroll through the menus there all jumbled. could pulling out a midi cable damage the code on the PIC?

This is a problem with the LCD module itself which is not laying out the text correctly. Someone (11Hz robot) had the same problem, and I had to reset the LCD module (you need an arduino or anything that can send serial commands to it + a lot of trial and error - I haven’t found a standard procedure to reset it). Trying with another LCD module will surely solve the problem - if you want you can mail it to me and I’ll reset it for you.

I’ll nag the people at sparkfun about it but so far they have been totally clueless.

dose

i mailed you there bout it

send the LCD to you today, cheers for the help with it

will they synth still work without the LCD? still messing with drivers/software for the midi thing as i think the problem is down to the cheapo cable

Yes, it works without the LCD!

Finally got things working despite having no lcd…

unfortunatly im not exactly sure what the problem was but it was either:

-windows7 default midi cable driver doesnt work, lots of mentions of it being problematic in OS’s after XP, theres a recomended driver here that work for it incase anyone else has gets one of these cheapo cables
http://www.emu.com/support/files/download3.asp?Centric=1009&Platform=1&File=550

-I installed this driver and sequencing midi from renoise worked, when i stopped playback the noise i mentioned before returned. i eventually found disabling midi clocks stopped this. so things arent working 100% but until i get the lcd sorted and a case made up its not gonna be a huge issue