Repairing an old akai s20 sampler

Hello all and happy new year

So I’m back with some non MI questions. Hope it’ll be alright, otherwise tell me and point me in the right direction (another forum).

I got a non working akai S20: No bottom plate, no floppy drive, and not booting.
I replaced the fuse and it did the trick. I mean at least it is booting.
So it boots, show how much ram I have installed and shows a “1” on the screen. According to the manual, it is the sign that the sampler is ready to operate. Only problem is that I can’t really do anything from there. Only the down right keys, the “+” and “-” keys, the tap key and the seq key work.
I can’t enter any edit mode. Really weird that some keys works, but not the others…
I’m now running without floppy drive, I tried with one connected, same problem…
The unit operates on 10V 850mA, as it would be a pain in the ass to find the right one, I am now using an universal adapter 9V 1000mA, it seems to work well.

So I’m looking for people with experience with this sampler who could help me…
Maybe I just did not understand the right operation procedure?

Thanks!

I do not have experience with this specific sampler, but Sample Wrench may be able to help you get around the lack of a floppy drive. Even if you can’t sample, you may be able to send it a sample over MIDI.

Just in case you haven’t be sure to read the manual, and service manual if you can find it. Some of these older samplers are pretty archaic.

@audiohoarder

Thanks, I’m under osx so this one won’t help me. I have two floppy drive around that both seems to boot fine with the unit.
I read the manual, I should be able to enter the edit mode and so on.
The service manual is impossible to find, if anybody has it, it would be really helpful!

Sorry, I wasn’t thinking about it being Windows only. I also figured that you had read the manual, but it is better to be sure.

As this is 10V unit, you may try the 12 V setting on your universal power supply as the voltage regulator should step the voltage down anyway. If you think it is the power supply, you can still buy a 10V Yamaha power supply that will most likely match the specs of the original AKAI one.
One last question, is the power supply needed AC or DC? I have had some synths not respond properly when I accidentally use a DC adapter instead of an AC adapter. For example, switches not working despite the screen showing that it is booted.

Yes i tried with 12v, the voltage regulator becomes hot (but there is quite a big heat sink) but no changes…
The s20 needs DC and that’s what I’m using… damn, I really want to resurrect this unit!

Hmm… Well I know that some of these older tack switches that are under the buttons do tend to fail. I assume that that you have tried pressing harder on the “stuck” ones for a longer period of time? If that doesn’t work, can you confirm if the buttons are still making a good soldered and mechanical connection to the PCB? You can try reheating or reflowing some solder over dry joints.

The first thing I would do at this point is try to record something anyway. Try sending a loud signal to see if there is an auto record threshold.

Man thanks a lot for your time!
I tried pressing the buttons hard, checked the connections…
There is a level indicator for the recordings, I tried to send something but no luck as I can’t initialize the record setting.
Could it be that a crucial IC is fried? I can report tomorrow with pictures of the boards.

It’s the Saturday after New Years. All I have is time. :wink:

The only “fried IC” I can think of is a multiplexer for the button presses. So if all of your non working buttons go to the same IC, that is the one to replace. It sounds like your EEPROM and ADC/DAC are fine since you are getting a level feedback from the input on the vertical line of LEDs.

Take your time with the pictures.

I wa not precise enough, I do not get any level feedback from the leds when I send an audio signal into the unit.

Ah, ok, that changes a few thing.

First double check that pressing record then a pad button (1-16) doesn’t put it in the default recording mode, stereo at 32 kHz. Make sure something is playing at the input as it will just start recording for the entire time RAM allows. Also make sure that your REC pot is all the way up.

It really almost sounds like it should work. The cursor going down and right makes perfect sense as the cursor should start in the upper left hand corner.

I tried everything mentioned, still the same behavior. You can see it in this small video I just did (crappy quality).
S20VIDEO
In the manual, it is mentioned that pressing any arrow other that up shows you the sampling time left. This is working.
I really do not know why some buttons and functions are working and why some not. All buttons goes directly to the ribbon cable and to the other board.
here are pictures:


Those ribbon cables look like a right royal mess. There could be a kink in addition to the coffee/cola/beer spill on the ribbon connecting the switch board to the computer PCB. The FDD ribbon lacks the crimp lid. Start by replacing those as it can’t hurt no matter what.

Ok, the first board with all the buttons looks fine to me. The 44pin ribbon cable being dirty shouldn’t be an issue, but it is a cheap thing to replace. You may want to try removing the cable then re seating it. I am sure you have already tried that, but sometimes getting perfect contact on all pins is a bit finicky. Are any of the pin holes clogged with dirt or dust? As the second board is mostly SMT there is very little chance that a short was casued due to the unit having no bottom plate.

At this point there are three places to check. The passive components that run to the ribbon cable on board number one like the capacitors and diodes. Then the ribbon cable and connectors themselves. Then the ICs after the ribbon cable on the second board. A closer picture so that I could see the number on them would be awesome.

One other thing to check, can you bridge the pins on the backs of the tack switches that don’t work to cause a connection as if you had pushed the button? This is an easy way to see if it is the internal components of the button that aren’t working as you will bypass them. Looking at the back picture, you can try bridging the vertical button pins with some alligator clips. You way want a mirror to easily see if anything on the front of the unit is happening.

Seconded. IDC cables have very thin wire and insulation.

Jojjelito The ribbon cables are a mess. The one connecting the switch board to the mainboard is dirty, but no signs from damage. The other one connecting thje floppy drive is naked because I had to insert a new ribbon cable into the bare connector (on the kind of metal blades). Why? Becaus on both ribbons, there are no male connectors, but the ribbon soldered directly on the PCB. I find quite stupid from akai. I should consider unsoldering both connector and soldering new male connectors, but the perspective of unsoldering 44 and 34 pins is not enjoyable (but feasible of course).audiohoarder
I’ll try to do the short thing on the buttons and report back asap!
In the meantime: more pictures of the ICS and the back of the mainboard





Thanks for the extra pictures. Honestly, I have had boards that looked way worse than this work. It really may just be the ribbon cable. That resistor soldered to IC30… man, you can tell this was a “budget” piece of kit.

The last time I had an issue with an AKAI sampler misbehaving the SCSI N25 fuse just decided to die while sitting on the shelf. Are there any other fuses aside from the main power fuse?

@audiohoarder
No other fuse, the one you see in the pictures is the one I changes, it is originally an SMT fuse (Who would do this?), but it seemed the previous owner already swapped it for a through hole soldered on the other side of the board.
Yeah I know this resistor on the IC… kind of a joke, I had an Ipod station with like tens of resistor added to smt…

But back to business: I shorted some buttons, you were right!
Buttons are reacting, all of them I think. Seems like I need to order like 35 new buttons?
Weird thing is, i am still not getting any signal input, seems like I can sample when I short the right buttons, but nothing is being recorded. Now that I look at the rec level pots, I have the feeling it might just be full of beer or whatever, and that the previous owner kind of scamed me when he said “last time I powered it it worked!” (like when was that, 1996? I found spider nests and a lot of scums inside…).
Do you think that a broken pot could cut the level and forbid audio from being recorded?
Is there a way to bypass this pot?
And last thing, do you recognize this sort of tact switches? reference? Same goes for the pots I guess…

Ok, great! I was right about the tack switches. :slight_smile: You can get them cheap. I had a similar issue with a Korg DD5 drum machine. The edit button died one day, no spills or anything. I am glad you don’t have to probe all of that 74 logic on the second board.

The pot may or may not be the issue, it could be the amp IC for the input or the ADC. If I had to guess, it probably is the pot though. It seems that it is just sending a digital signal to the second board to control the VCA.

I will not recommend sending a voltage to the out pin of the pot as this can cause some interesting issues, and I don’t want you frying your board!

Any tack switch with the same 4 pin foot print should work. If you are in America, I will recommend Microcenter to you as you can go in and look at the type of switches for hobby kits that they have. They look exactly like them in the pictures.

As far as the pots, is there a part number? They look quite different from what I am used to. 5 pins instead of 3. Like I said, I think it is sending just digital bits to the CPU, so DO NOT APPLY ANY TYPE OF VOLTAGE TO THE OUTPUT.

The two pots have 7 pins, I also am not used to this kind of pot.
They are labeled as Alps 103A86t.
That’s all there is…
Before ordering some switches (I’m in Europe) I really would like to solve the in signal problem though…

I’m not even sure that these pots send only digital data to the brain, as when I turn the main volume pots, I hear scratches, pretty much like in an old amp or mixer.