Repairing a Grids


#21

I don’t see this mentioned on this data sheet.

The data sheet gives C-load of 18pf, this is attained by using 33pf at C2 and C7.

The google doc BOM calls for 18pf at C2 and C7, which technically, would out of spec.


#22

It depends on the crystal, those sold by Mouser normally work with 18pF, while the ones sold by Reichelt definetely need 33 pF (as per data sheet and experience).


#23

To be clear, the 18pf spec listed in the datasheet for the crystal sited in the BOM from Google docs, is a “TOTAL capacitive load”. To satisfy that spec, C2 and C7 must be 33pf. I’m only speaking to this data sheet and the spec as listed. I would to see the spec sheet from Reichelt, can you link me?


#24

IANAEE, but the Microchip data sheet to which you refer is for super-low-power sleep applications, where stray capacitance is likely to be a particular problem. However, I note you refer to residual flux on your PCB, and I think that’s your problem. In fact, the application note to which you refer warns:

Once the crystal is soldered to the PC board, it is critical that all flux residue is removed by thoroughly washing the PCB with clean water and drying with hot air. This is especially true when hand-soldering prototype boards. If the board area surrounding the crystal is not cleaned, excess stray capacitance and leakage paths may cause the crystal to be off-frequency or experience other abnormal behavior.

I suspect the source of your problem was inadequate cleaning of your PCB after soldering.


#25

Sure:


Sorry, there is only the germanized version :wink:


#26

I take your point BB. I was removing the flux cleaning the PCB when I discovered the odd behavior. So flux being the problem, doesn’t feel like a likely answer. In this case, the proof is in the pudding. After installing the 33pf caps, the module works perfectly and is very stable.

Here is another link explaining the math: https://www.lpcware.com/content/faq/how-calculate-value-crystal-load-capacitors.

Here is another link explaining the same thing: https://blog.adafruit.com/2012/01/24/choosing-the-right-crystal-and-caps-for-your-design/


#27

Yes, but thousands of MI designs, including Shruths as well as eurorack modules, use 18pF caps, and they work perfectly and are very stable. Your single anecdotal data point obtained from a PCB with residual flux on it proves nothing. A cotton swab dipped in alcohol is unlikely to adequately clean away the flux, it needs multiple scrubs and lots of solvent for adequate cleaning.


#28

I’m sensing a hostile tone here, maybe it’s just me.

I’m really not here to accuse or assign blame, BB. Like I said, I’m just sharing my experience in case someone else can benefit. I thought it would be beneficial to lay out how I arrived and my answer for my situation. I’m not condemning design choices OG made in his designs.

Furthermore, I understand there’s a lot “noobs” and “greenhorns” in the SDIY scene, but I think blindly assuming that whomever you’re communicating with is a know-nothing is not helpful of even kind for that matter. I’ve been a repair tech for 16 years and even have done repair/assembly for a modular synth company. With respect, I know when a PCB is clean and when it’s not.

If you think my posts are somehow inflammatory, unfounded, or misguided - I’ll gladly delete them.


#29

I’m not being hostile, I was just questioning whether your advice is well-founded or not. Recently I was shocked to learn that not every piece of advice found on the Internet can be relied upon, at least not prima facie.


#30

Fair enough, friend!

I’ll let it sit, people can choose to take it or leave it.


#31

Hi there! :slight_smile:

I just build the Grids module and uploaded the code. Built according to BOM at Mouser. Firmware seem to work fine, but the crystal won’t affect the clock at the right rate. I need to hold the Tap button for approx. 8s to activate advance options. I programmed the chip after I have soldered everything to the PCB. Should I now just remove the crystal and repeat the programming of the chip via ISP pins on the back? Thanks for any advice…


#32

You have probably forgotten to set the fuses.


#33

See up-thread, specifically here.


#34

Thank you so much, BB! Bake truly works wonders… Now, to share my journey and mistakes I’ve made, maybe there is a noob like me out there that wanders around…

I’m using Pololu USB AVR Programmer V2;
installed Crosspack for Mac (part of it is AVRDUDE that you use for communicating with your ISP and AVR), Pololu Library and Pololu USB AVR Programmer V2 Software (very handy for adjusting/reading the preferences of the programmer).

I followed the steps for Grids described <href=“http://mutable-instruments.net/forum/discussion/4344/mac-tutorial-how-to-compile-and-upload-the-firmware-of-mis-eurorack-modules/p1”>here.

1. Open Terminal and enter: “cd /§pathToEurorackFolder§/” - OK
2. To compile: “make f /§ModuleName§/makefile” OK
3. To upload: “make f /§ModuleName§/makefile upload” in accordance to BB’s comment I changed upload with bake, but the Terminal returned an error that AVRDUDE couldn’t connect to the m328p and that I should double-check the connections. Well, I didn’t know I had to connect the Grids to power. The programmer software reported 3,3 V, after powering it the power rose to 5 V and the transfer (bake) of firmware was successful. Also in the programmer software I had to change the version of stk500 from the default v2 to v1.


#35

I’ve got two old grids I am also trying to resurrect, i think the serial numbers are 119 and 120, they were most definitely abused so I would not expect any replacements. I’m trying to use a usbtiny to connect and can’t seem to connect even after having replaced the atmega328p. @BennelongBicyclist mentioned its soemtimes difficult to get avrdude to recognize the chip without fuses set. i’m a little confused about how I can set fuses when avrdude doesn’t recognize the chip. i’ve tried -F to bi-pass these initial checks but still get error message that the chip is returning
avrdude: initialization failed, rc=-1
avrdude: AVR device initialized and ready to accept instructions
avrdude: Device signature = 0x000000
avrdude: Yikes! Invalid device signature.
avrdude: Expected signature for ATMEGA328P is 1E 95 0F
avrdude: NOTE: FLASH memory has been specified, an erase cycle will be performed

i’m getting an olimex to see if that does a better job, but i suppose I’m impatient. any tips would be most appreciated. I hate broken things :wink:

also if anyone has the schematic to the v .1 that would be amazing! this link is dead now http://mutable-instruments.net/static/schematics/Grids-v01.pdf


#36

You’ve probably forgotten the flag to lower the transmission speed (-B 10)


#37

Hi Bennelong, when you say "Replacing upload with bake, what do you refer?, I have your same issue, my grids is tempolow after the upload of the firmware, I am new on programming.

thanks in advance

fernando


#38

ok done, for the next newbies like me, install vagrant, install virtualbox, install winavr, and drivers for your programmer. After compile the grids with make -f grids… like Olivier describes.

1.- in terminal go to mutable-dev-enviromment-master\eurorack-modules
2.- write the following:

avrdude -V -p m328p -c usbtiny -P usb -B 4 -U flash:w:build/grids/grids.hex:i -U lock:w:0x2f:m -U efuse:w:0x05:m -U hfuse:w:0xd8:m -U lfuse:w:0xff:m
3.- enter

in my case I use an adafruit usbtiny selfpowered, put your programmer and connect the module to your eurorack power supply, not in my case

Ok I hope that helps to others.

Fernando.


#39

Hi Oliver,

I accidently plugged my grids in wrong and now it won’t power up. I had a look at replacing the regulator but mine is the first version. Do you know anyone who could repair it?

Thanks
Jack