Problems programming Shruthi-1 with Atmel Studio 7

Hello.
First of all, I want to say that I’m not a programmer and i’m very confused with all this.
I recently bought this AVR ISP mkii Programmer


and I want to write .hex files (muboot and shruthi1), the internal eeprom and write the factory data

After trying with lots of programs, it seems that Atmel Studio is the only one who recognizes my AVR mkii USB device, so I’m trying to do all of that with it.

What i’ve done until now is to write shruthi1.hex file and now I can see all the letters and stuff on the screen of my synth. No sound yet. I don’t know how to write the muboot.hex, since, according what i’ve understood so far, this program allows me to write only one .hex file.
On the other hand, when I try to write the internal eeprom, I have this error:

“Unable to parse objectfile D:\Descargas\progisp172\shruthi 1 code\internal_eeprom.hex: Unsupported format.”
I think it’s asking me for .eep file instead .hex.

And at last, when I go and try to change lockbikt to 2f, i hit program and then it automatically changes to 0xEF. Is that fine?

Please help me, I’ve been dreaming with shruthi-1 sounds for so long…
Thanks

The warning is not a problem - I think it’s because the most significant bits are not used.

Regarding the bootloader… Your programming tool doesn’t have the option of writing both files at the same time. You can try writing the bootloader first, then writing the main .hex file (this time by carefully disabling any setting that would re-erase the chip). If it’s not possible to do that, another option is to just write the bootloader, then load the main firmware by MIDI.

Once you get the main firmware loaded, you can dump the factory patches by SysEx. http://mutable-instruments.net/archive/firmware/shruthi1_factory_data.syx

Oh thanks a lot.
2 questions.
How do I know if I wrote the muboot.hex file successfully?
And how do I write the factory patch, i mean the .syx file?

Ok so I just tried and got this.

You can know that the bootloader has been installed correctly if the synth can enter firmware update mode (press the encoder when it’s powered on, check that you see LEDs 1 3 5 and 7 lit).

The patch data is NOT the same thing as the firmware. You shouldn’t follow the “how to load the firmware procedure”. You should just play the .syx file with the patches into the synth while it’s powered on normally.

Your error message is not related to the Shruthi, but to your computer, MIDI interface or a bug in MIDI-OX.

It’s working!!! Woooow thanks a lot!!!
Just a final question.
What does the factory patch do?? I’m not sure if that finally went well

These are the 144 or so preset sounds.

1 Like

Great! I had problems with c6 and MIDIOX but then I downloaded MIOS studio and it finally worked! :smiley:

Another thing I notice is that I don’t have sequence patterns in my shruthi. I was watching a video on youtube where this guy could navigate into it. I did the same and nothing happens, I can’t get to this screen. Is there something i’m missing on the uploading part? Do I have the wrong version or something?

Thanks a lot!

Hi,

You need to check the manual :slight_smile:
https://mutable-instruments.net/archive/shruthi/manual/

Button 5 toggles between synthesis and sequencer pages (which can be a bit confusing in my humble opinion), so when your in synthesis mode you cannot access the sequencer pages.

I hope this helps.

Cheers

I’ve been trying to understand by reading the manual but I simply can’t access browse sequences. I just have:
“browse : patch
save : patch
compare: patch”
when I press button 6.
When I press button 5 i get the
“Mod bpm gro amt” screen, and if there i push button 1, i get “Dir rng pat div” which is related to arpeggiator, not sequencer.
I’m confused please help me :sob:

Yes, but as shown in the illustration under “Controls and navigation”, some buttons cycle between several pages (1st, 3rd and 4th buttons). I don’t want to sound unhelpful p, but I don’t think anyone will be able to give a better explanation than the one in the manual.
Cheers

I have read the manual twice today and there’s not information about this screen or how to access to it.
image
I’ve tried everything, believe me.
I’m beginning to think It has something to do with the firmware upload or something like that… idk, please help, I’ve read the manual several times and the answer is not there
Thanks :slight_smile:

Ahhh, if it’s the specific browsing of sequences you’re after it’s probably obsolete functionality. The video is done using official firmware version 0.97, and since version 1.01 sequence is saved together with patch. See change log here: https://mutable-instruments.net/archive/shruthi/firmware/

Cheers

1 Like

Ooooh I see.
In this old version it’s easier to play live due to this very useful function of sequences storage and patterns…
OK, so now I’m trying to downgrade to 0.97v and it seems that I cannot do that. I’m trying to do it in a new ATmega644p chip, so it should work.
Now… I have the shruthi v0.97.hex file but I’m having problems uploading bootloader and this file, it seems that they’re not compatible or something… is the muboot.hex used the same?

How can I proceed?
Thanks a lot!
:smiley:

The bootloader hasn’t changed. It should be the same procedure.