Problem with display (Shruti Yellow Magic) : some characters are not complete [SOLVED]

Hello
I just finish a Yellow Magic Shruti, everything works very well but …

I have small problems with the display of Yellow Magic , some characters are not complete
I checked and re-welds
In your opinion : bad installation or bad screen ?

Thank you !

Photos with two different brightness adjustment :


I specify that I set the screen to tilt it like this :

Mechanical stress to the Bezel/PCB so the Screen is bent.

+1. This looks like the result of uneven pressure applied to the LCD film. Nothing to do with electronics.

Ok I see : when I push the surface of the screen, the default increases or disappears.
Yet, I have not damaged the screen, I just get out of the bag …
When I twisted a little screen nothing happens : neither better nor worse
No idea Magical repair ?

Did you bend the legs after soldering? I this could put some stress one the display.

No i bend the leg before soldering …
But It is possible that I twisted it up a bit by trying different positions .
I think I’ll have to find another …
@Pichenette you don 't have more in your archives? It was “Yellow Magic” kit batch 2 …

Thank you all for your answers !

I can reorder one…

Hm, as it looks like some bending or pressure on the bezel, i personally would give it a try to reheat the solder joints to release it. If you are fit enough in soldering i would try to heat up 3-4 pins at a time, so you should have a good chance to get rid of the bending.

Yes i can try that, but i think that i bend the bezel before soldering …
Thank you

NEVER bend the bezel. You cant make anything better…
Just reheat the Pins one by one to take the mechanical Stress from the LCDs PCB. This can happen if you solder them in a straight row - just like with the Wheel of your Car you shouldnt solder these connectors in a line (worst with high temperature), better is starting at both ends and PingPong…

I wanted to say that I think I had already damaged the screen before welding …
I tried to reheat the solder but it is the same …
I fear it is a lost cause … !

You could maybe try taking the bezel off? If you bend the ‘thingies’ on the back you should be able to take it off… I never tried this so i don’t know what will happen maybe the whole thing falls apart?

Oups … there may also be an electronic problem now ! ( but ok on reboot )
I’ll stop trying to fix it :slight_smile:

New screen ordered and received, thank you Pichenette, I replace it next weekend

I replaced the screen and everything works perfectly !
A new Shruti is born :slight_smile: