Power testing fail

I’ve assembled the power supply section of the SMR-4 board, and so got to the testing section in Step 4. Something is wrong already :frowning:

Basically, I get no voltage anywhere on the board. I tested the multimeter on my power supply, and that showed power coming through just fine, so I know the problem isn’t with the multimeter. The power supply, incidentally, is a regulated 300mA AC/DC adapter with adjustable voltage and polarity (I assume regulated is okay?). I’ve got it set to 9V, centre pin positive - it’s the same power supply I used with my Shruti-1, although it was known to be a bit temperemental. I seem to remember not being able to find a suitable tip for it which exactly matched the Shruti-1’s power socket, so you had to be careful not to move it once it was switched on.

Anyway, when it’s plugged into the Shruthi-1 SMR-4 board, no voltage. Even testing the centre pin point on the socket against the outside of the power supply tip shows nothing at all. The soldering on the socket looks fine, although even if the soldering was a problem I’d expect to see a voltage on the socket.

What could this be? Faulty socket? The fact the power supply is regulated? Or is the socket different to the Shruti-1, and needing a different adapter? The Shruthi-1 manual is a bit vague on the socket, it just says it’s a 2.1mm (which I guess is the size of the inside pin), but doesn’t specify the size of the socket as a whole… 5mm? 5.5mm?

First of all, the DC jack and the whole power supply section of the circuit is overall very similar to the Shruti-1 - so if your adapter worked on the Shruti, there’s no reason it won’t work here.

The very first thing I would check is the voltage between the ground (for example, the “GND” pin on the circuit and the “bridge” labelled SW. This should be whatever voltage your supply delivers. If there’s nothing here, it’s likely that there’s short between GND and one of the power rails. Use your meter in continuity testing mode to check for that.

My meter doesn’t have a specific continuity testing mode (i.e. it doesn’t beep), but it does have a symbol that looks like |>| (where the |> is a filled-in black triangle), which I guess tests resistance? It shows a “1” when the tips aren’t touching, a “000” when they are, and some other value when they’re connected to (for instance) the two ends of a resistor.

Checking the points that are marked on the board, I see this:

  • Connecting any 2 points of the same colour shows “000” or “001” (i.e they’re connected, with little or no resistance)
  • Connecting a blue and a red point shows “1” (i.e. no connection). Likewise connecting red to green.
  • Connecting any blue point to any green point shows “1129”, or some similar number.

I’m guessing that means there’s a short between the -5V and ground? How do I go about tracking that down to a more specific point? The soldering all looks fine to my eyes so I don’t really know where to begin.

Hi,

I´ve got a similar problem:

the red points work fine but the green ones doesn´t show anything.

What could it be?

@ernst bitter: Check that the LT1054 is correctly insert and oriented. Also, check that the voltage on the metal frame of the 7905 is equal to the opposite of the supply voltage.

To clarify: There’s nothing between GND and SW, which is why I tried the continuity test like you suggested. Any ideas about how I could narrow down the problem?

Regarding the resistance measurement between GND and the supply rail, it’s normal - I get numbers similar to yours.

Try measuring the voltage between GND and the back of the metallic “back” of the DC jack. If you don’t see anything, it’s likely that the tip of your supply is faulty and doesn’t have the right diameter - just a mating problem.

I don’t see anything. So it’s a badly-fitting power supply tip, then? What dimensions of tip should I be looking for as a replacement? 2.1mm on the inside and… what on the outside?

Here is a drawing of the part

Yes that was the problem, now it works, thank you!

@ElectroDruid: maybe try some other power supplies. I also have one which doesn´t work although it matches the preferences and isn´t broken (=works with other gear without problems)

Just went and bought a new tip for the power supply, 5.5mm x 2.1mm. Feels a bit loose in the socket, but it works! Yay! From the diagram I guess the ideal tip is something like 6.0 x 2.1 but my local electronics store doesn’t have any tips like that, and doesn’t have any power sockets that are a different size. Anyway, I thought it was worth mentioning in case anyone else had problems with their power supply.

FWIW, the mode you were describing on your meter is actually diode test mode. It’s similar to resistance mode on the lowest range (probably 200), but it applies a higher test voltage through the leads than the other modes so that it can achieve the necessary .7V to forward bias a silicone diode.