Power supply section problem, or I'm dumb

Hi there!

OK, it looks like in my haste to get my shruthi built I made a boo-boo. When I went to test the voltages I got behavior just like this > http://mutable-instruments.net/forum/comments.php?DiscussionID=397&page=1#Item_0 < and sure enough, my 7805 and 7905 were flipped (doh!)

I tried desoldering them and slotting them back in, however I’m afraid I might have fried one (or both) in the process as now when I test I get 5v from gnd to all the red points, but 0v from gnd to all the other points. (I hope this wasn’t a bad idea, but I tried measuring from 5v to the same points out of curiosity and got -4.9v)

Does anyone have an idea on what might be the problem? Is there any likely causes for this issue and if it’s one of the components I desoldered any idea which one it might be?

Thanks!

What is the voltage out of the LT1054 (at the input pin of the 7905)? It looks like you:

  • fried the LT1054
  • or badly resoldered the 7905

edit :slight_smile:

Hi pichenettes,

Thanks for the prompt reply!

Anyhow, sorry to be a bother, but which pins should I be measuring from? I’m afraid I will fry something if just try poking around :slight_smile:

Thanks!

You won’t fry anything by measuring voltages.

The output of the LT1054 is the 8th pin of the chip. You should read here a negative voltage - the opposite of the supply voltage (for example -9V).

cool, sorry for my basic questions…still learning here :slight_smile:

OK, yea I’m getting -8v when I measure from the 8th pin to gnd. (with com probe at gnd) but nothing when I measure from the 7905 to gnd.

Is this the correct way to measure?

I guess I got confused as you mentioned the input pin of the 7905, so I wasn’t sure if I was to measure from the LT1054 to the 7905 or from the 7905 to gnd…

if you have different readings between pin 5 of 1054 -> gnd and input pin of the 7905 (middle pin) to gnd, then there’s a bad solder joint

hmm, cool, I guess it must be an issue with the 7905 then, thanks guys…is there any way to test if the chip is fried?

I’m hoping it’s just a bad solder on that thing, will get back to you guys in a bit!

If it makes you feel any better, stephenmm, I got the two voltage regulators the wrong way round, too. Easy mistake to make…

a|x

wooo! OK, I managed to get it all working. That little guy has some punch!

Thanks for the help guys, it’s really great to FINALLY have this built!

Now I just need to build that wooden case I’ve been dreaming of… (and maybe tune it? seems to sound pretty good already but I’ll poke around a bit I think)

Glad you got it working!

a|x