Polivoks filter almost no sound in LPF mode

Shruthi, Polivoks filter. Set Filter type to PVK.

However, when I’m in Filter Mode LPF, there’s almost no sound – perhaps 10% the volume when it’s in BPF mode. I tried changing a bunch of different settings of the Oscillators and Filter, but nothing I do will make LPF mode have a normal range of volume (to hear it I have to turn my Mixer up to a crazy level).

The only thing weird I see on the PCB is there’s R32 and R33 but they aren’t listed in the BOM and the schematic says 0 here. Are they supposed to be jumpered with wire? (later: put wire here, didn’t help).

I also checked and there is continuity from IC6 PIN 6 to IC9 PIN 13 (LPF pathway). VCC / VEE is OK and all pins on IC6 and IC5 (LM4250CN) are checked for continuity to their nearest neighbor.

What am I doing wrong? Or what might be wrong with the filter board?


1 Like

Edit: Putting wire at R32 and R33 actually made the Overdrive stop working, so I removed it. It’s a bit confusing because the official pic of the finished board shows nothing here, but the PCB diagram shows it bridged, and the schematic shows “0” which I would assume to mean it should be bridged. But bridging R32 and R33 seems to have a bad effect.

I’ve now reflowed the entire board, verified all of the point-to-point connections in the audio pathway, checked the values of all resistors and capacitors, replaced the LM13700, TL084, TL072, and swapped the two LM4250. I also tried bypassing the 4053 switch and connected the LP mode directly (pins 14 and 13). Tried a different top control board. Tried the YAM firmware. No change at all.

I’m totally stumped. Filter sounds great, but it’s still nearly inaudible in LP mode… at this point I don’t know what else to check as I’ve verified everything that I know how to do.

Here’s a pic of the board. I’ve triple checked everything, compared it to the photo on the official Shruthi Polivoks page… still can’t find anything wrong. Parts are all legit from Mouser.

Hi , remove IC 4053 . Take a oszilloscope and look what happens on MIX input. . You should have a signal 1,5 …1 ,6 Volt peak peak… Than look what happens on IC 6 LP out … Test also C 27- 4,7 uF. I had sometimes the problem that the Caps loose tis capacity. and than it gives the same effec you describe. Use a normal one 4,7…10 uF for testing .
You can make a short between PIN 13 X1 and pin 14 X (without IC 4053) to test the VCA wit a signal .

I fixed it! The problem was the LM4250 chips. I replaced the LM4250 for LP with a few extra I have until I found one that worked. I got them from UT Source because LM4250 are obsolete and not available from Mouser. I tested and 6 of 10 don’t work!