Only ADSR values r flikering

New shruthi-1 and only the envelope values are changing on their own, both envelopes all four values per, everything else is stable.

Tried this stacked with an smr, and also disconnected with only the +5 and ground jumpered over.

Sounds, presets, all four pots work on other pages. I have a sinking feeling it might be the caps soldered under the LCD?

The other thing going on is Frank’s programmer is built and sending tweaks on the other three ports/pages/cables. I checked continuity, tried swapping the 4051 chips for porst 3 & 4, and then also chaneged the cables between port 3 & 4. Same issue, so now I am convinced its in the digital board itself.

Mostly the second values changes on all four with a slight lag between them (clock?) Cap? Is there a test point or key solder point to chcek. It does this even when the cable to the programmer is disconnected. No changing values on any other page. I’m thinking its a solder to ground?

I don’t think its the pwoer supply, tried a 600 ma as well that works with anotehr shruthi. And if it was all values all pages would flicker probably.

Could it be in the atmeg. It was in its socket, poweroff when I added the prommer cabe.

> I have a sinking feeling it might be the caps soldered under the LCD?

Hmmm, what’s the thinking behind it?

> Mostly the second values changes on all four with a slight lag between them (clock?) Cap?

This is normal, the programmer reads the pots sequentially, with whatever CPU is left available by the chip, so the refresh rate is not stellar if many parameters are changing at once.

If it were the stability of the ADC, or anything with the digital board, how would you explain that only the values on the ADSR pages would be flickering? First thing, try disconnecting the programmer and disabling it (cv. : 4cv). Is the problem still there?

This sounds more like a noise pickup problem in the programmer.

Yo, Lorne

First, disable the Programmer in the System Pages and check the onboard Pots. If everything works its a Programmer Problem. Only disconnecting without disabeling does NOT work, as Shruthi still thinks the Programmer is there and scans for Values. If nothing is connected it will read random Values from the unconnected CV1in Port which results in these random Values.

If its a Programmer Problem it must be around Port 3 - you said you swapped chips, so on the Frontpanel everything should be ok, maybe its a bad solder Joint somwhere around 4051 #3, my best guess is the Output Pin, since all 8 Values seem to float to your description, see here in the Pinkish Rectangle, Red are the Outputs from the 4051:


Seen from ABOVE! Reverse in your Mind when looking from the Copper side - or just use PhotoSh*p.

Try resoldering some of these pins, specially the one in the Pinkish Rectangle.

Also :

Flickering as in “random value irrespective of the pot setting” = floating 4051 line.

Flickering as in “moving a few digits +/- the value of the pot” = noise pickup problem.

FCD72, thanks again for the offline emails. Thanks pichenettes.

Community update, it was a melted trace on the 4051 socket on port 3. I kluged the gap with insulated wire and everything is rock stable. Before I did that I had swapped chips and cables and thought I’d done all teh continuity (wrong).
What really threw me was the flicker was there in the digital display cpu when the programmer was disconnected. Trace repaired, zero flicker.

The melt was where the red trace bends between the two pins above the red pin on port 3. Looked so obvious once I looked there. Duh. Gotta ditch this old wide and fat weller tip for something with a fine point – or get new glasses & a new brain. Thanks!

The red beast is now running and tweaking on all engines.