No MiDi in

This morning the bad surprise. When I assembled the unit I used the self-tuning tone to test it and everything was ok. Unfortunately today I wanted to play a little bit with the shruthi but it seems it can’t recieve midi from my keyboard (or pc).
how can I check if something is wrong? For example if the opto-coupler is not working properly.

Use a scope to look at the signal at the output of the opto-coupler (pin 6). You should see rectangular pulses with sharp edges.

Did you use a 6N137? The 6N137 and 6N138 are not equivalent, you need to use a much smaller pull-up resistor if the 6N138 is used.

I confirm 6n137. Unfortunately I don’t have a scope, so the only thing is to buy a new one and see what happens.
I have triyed midi out too and it seems to be mute aswell.

If u got a problem with out, it’s not an opto issue…

Let me understand: the opto is uded to calm the intensity of midi in, so it does not deal with midi out, right?
So if midi out is not working too, it’s not the opto.
What else can I check?

The opto is isolating the device connected to the MIDI-in from the Shruthi, so they don’t share bodily fluids noise.

What are you doing to test the out? The only way to test it would be to do a data dump or play a sequence.

If you notice that the Shruthi is badly out of tune, it might be that you used a quartz at a different speed than 20 Mhz. In which case the timing of the serial MIDI signals will be wrong. But that would be a weird mistake.

In fact I used a sequence and I’ve checked if my audio interface recieved midi data, but nothing.
The quartz is a spare from mutable shop. It has R200NKB0b printed on it.
How can I perform a midi dump, just to verify all I can verify?

Midi channel ok? midi cable ok? try to connect a LED with + to pin 6 of 6n137 and - to ground
midi signal in the presence of the LED lights …
Double check if something is off does not work between the connector and the microcontroller …
empirical method and crude but functional!

On the load/save page press Switch 6 + Switch 4 (hold 6 and press 4). Turn encoder so it displays “ok”. The Shruthi must spit 80 SysEx messages.

Ok, I’ve performed a midi dump and it worked, my audio interface recieved midi data. So Midi Out is working.

Then I’ve tried what ilpitu said: the long leg of a led to the pin 6 of the opto (red point in the first pic) and the short one to the ground (green point in the second pic). No led light, nothing at all.

first pic

second pic

Any idea? I’m checking all the soldering points, but it’s not easy as the LCD is already mounted (damn…). As soon as I can I’ll go and buy another opto, so I can see what happens.

I’ve bought a new 6n137, mounted it on the digital board but nothing changed… still no midi in.

I don’t know what to check to know what is wrong.

Is there a way to check with the multimeter if current/signal/whatever goes from midi pin 4 through R19 into octo pin 2?

Things to check:

  • ESD having damaged one of the AVR pins? To test: swapping the AVR chip with your other Shruthi.
  • MIDI cable. I struggled for 20 min yesterday with a MIDI out problem which was due to a bad cable.
  • Is the 6N137 receiving power correctly?
  • What’s the resistor value for the pull-up?

Nothing would beat scoping the signal on the 6N137 output, though…

Sorry Olivier but I was editing my post while you answered me. So, what about multimeter?

About what you wrote me:

  • I gave my first Shruthi to my best friend and now is 1000 km away from me, no swap possible (what is ESR, btw?)
  • I’ve already swapped and checked 2 midi cables, the problem is not there.
  • for the 6n137 power, how can I check it?
  • R19: 220 ohm +/- 1%

Multimeter are too slow to “see” MIDI signals. But you could still try probing the opto out: it should be a 5V and drop to 4.7V or something under heavy MIDI traffic (such as a massive sequence of SysEx).

Voltage on pin 8 of the 6N137 should be +5V.

ESD is electrostatic discharge, and why collecting antique carpets and playing with electronics are not compatible hobbies.

Just a dumb question, couldnt you SEE the Midi Data with a LED + 220R to gnd probing the Out Pin of the 6N137 ??? Not exactly a Scope but better than nothing . . .

the LED could be blinking too fast for the effect to be noticeable. After all a full MIDI message takes only 1 ms.

1ms could be a bit short - maybe then use your PitchBender? Or a JX8-Ps Aftertouch??

Ok, I’ve measured voltage with the opto unmounted pointing the com probe in the pin 5 and the other in pin 8. The multimeter says 5V. Then I mounted the opto and I’ve measured again the same pins and I’ve found -5V. I suppose this is not normal.

Humm, maybe you swapped the two probes when you did the second test?

Exactly, sorry… please be patient with this humble noob.
I’ve triyed with a led putting the short lead on opto pin 5 and the other on pin 6. The led doesn’t lit during midi massive sysx. The resistor helps slowing down the led blinking?