News from the MIDIpal code sweatshop

ok, i’m back.
any news from the sweatshop?
anybody been able to reproduce the sequencr app memory glitch i described above?
or should i send in my midipal?

I could not reproduce the problem.

hm. anybody else, then?

I have also tested the new firmware and in the beginning it seemed to be the same effect like mic.w.
But after a it works pretty good. Nice feature!

yay, just saw that midipals are back in stock - and immediately ordered one!

let’s see if this new one is going to show the same issues with the new firmware, or if maybe it’s a hardware issue on my first mp…

i’s so love to see this new version work without issues, because the new 101 note clock thing is brilliant!

Upgraded. Reset.
Arp - clk not - does not work. ext/int Work
Delay - fine on normal modes, i dont understand how clk would work here
Scale - seems fine, never used before


I havent found anything wrong with any other apps but the clk doent seem to work on anything.
Yes I have disabled the Tempo transmit on my Machinedrum

Have you set the channel and note?

The older version works fine tho.

Just put it back on, I dont think I did.

Right, that was it.
I’ve got MD>Midipal>Shruthi
clc 1
cln off

When recoding noted in, I seem to be better in int mode or it plays the first note for every second key press. Maybe Ive done the setting wrong?

Arp only seems to spit out 2 notes, not going through its sequence.

Are you using the same channel for the arpeggiator/sequencer, and for the clock note?


I don’t understand anything at all!

What is the value of the chn setting of the arpeggiator and sequencer?
What is the value of the clc setting?
What is the value of the cln setting?

  • Are you using the same channel for the arpeggiator/sequencer, and for the clock note?
    Yea… which is the play command and which is the pitch command? Sorry, I’m probably doing everything wrong.

Yes, you are doing it wrong!

Situation 1:

You want to use the same channel for note clock messages. In which case you have to be specific about which note is going to be used to step the clock so that it does not have side effects.

clc = channel number
cln = note number for stepping the clock
chn = same channel number

Situation 2:

You want to use a different channel for the note clock messages.

clc = channel number of clock
cln = note number for clock, or off if any note can be used
chn = another channel number

Having clc = 1 ; chn = 1 ; cln = off will cause any note played on channel to have two effects: step/start the clock and change the sequence or arpeggio. Don’t use that!

Right, on Seq

Recorded 4 notes fine. This works but the sequence is pitched to the cln note. (There is a little quirk which I know is the MD C8 is C7) Changing the cln note and triggering that alters its pitch.

Recorded 4 notes using chn=2 fine. Tried triggering with channel 1, just acts like normal midi rather than going through sequence
Changed cln to a pitch, still acts as a normal midi note.


Playing a 3 not F chord. 16 triggers. Works. But once again the root note is the clk note, if you change chord, it plays first note but then jumps back to clk note.
Works rather slowly, changing div in settings from 16 to 4 sorts this.

latch on
Same as Seq, even with cln set to a pitch

Am I doing this right now? Off to bed. More tomorrow.

I’ll spend 1 hr tomorrow trying to see if I can reproduce and fix the problems.

If after 1 hr, things are still going wrong, I’ll revert the code and we’ll have to forget about that.

Having a lot of bad feelings about this, sorry. Even correct, the code just smells bad. I feel it ultimately impacts the people who wants to have the latest MIDIpal firmware tweaks I have made (like CC control) - without all the horrible mess and instability introduced by this wart. Clocking system is very critical - such a feature should have been planned from day 1. I’ll think about it in whichever new product I design - but the MIDIpal firmware is unfortunately not something I have time to rewrite from scratch.