Midipal CCize not working

Hi,
I am having trouble getting the CCize to work.
I want to send Note values to CC34 [Comb filter’s Pitch on Octatrack] to control the pitch.
Sending the Sysex via Elektron C6. The Midipal seems to get it while it indicates PRG1.
Not sure what I am doing wrong here.
If anyone can help I’d really appreciate :slight_smile:

What is the problem exactly? How does the Octatrack react? What do you think it is receiving? These things are best troubleshooted by running the output of the MIDIpal into a MIDI monitor app!

One quick observation: do you want the velocity or note number to be converted to the CC value? Your screenshot doesn’t show if you have ticked the “swap source” box.

Thanks a lot for the quick answer :slight_smile:

I’m not sure the Sysex file is loading properly, because if I put ‘CCize’ only, the notes still pass through.
[Though I can see the LEDs activity when I send the file].

The CC 34 is not moving on the Octatrack when I play notes. Just notes.
I want the notes to be converted to CC, not the velocity.

“swap source is not checked”. Should I check it?

Thanks!

Note MIDI message: data A = note, data B = velocity
CC MIDI message: data A = CC number, data B = CC value

If you don’t check “Swap source”, then the value assigned to the CC (data B) will be the velocity (data B). If you want instead to assign the note number you’ll need to check “swap source”.

As for the reason why the MIDIpal doesn’t receive the user program, I’m not sure!

I ll monitor to see what’s going on at the OUT port.
And I ll check “Swap source”. Makes sense
When I send the Sysex, should I be on the program with or without [brackets]

Thank you!

I think it received the user program as both LEDs and PRG1 flash when I send it.
But still no luck. when I monitor the midi, just notes are sent.

Just to be sure, the settings I entered in the programmer on the screenshot [except “swap source”] are correct?
I ll keep trying and eventually figure it out!

  • Are you sure of the channel number?
  • To rule other problems out, have you tried simpler configurations? (eg, something like adding or setting the note number on all channels).

I tried that yes.
Not sure why it isn’t working.
I ll keep testing today I must be doing something wrong

Hi

I figured out that I omitted to put a delay of 250ms in the C6 settings, which was probably preventing the sysex to write properly

Apologies for wasting your time, I overlooked this…

Now everything works and it’s great :slight_smile:

Thanks again for the support and making this useful device!

I’m glad it’s sorted! If the packets are sent too quickly, the MIDIpal can still be busy writing the first one while the second one has arrived (and there is not enough RAM to buffer it).

1 Like