MidiALF!


#501

lol, dont know if I can wrap my fragile mind around 37 lines of code


#502

never ever… and in fact its only 6 Lines….
Im the Software Überhero and you may now call me Olivier the 2nd :wink:


#503

I like your coding, or rather commenting style. Nice read!


#504

Coding is hard work so it must look very serious, you know?


#505

@altitude
Generally your DINsync 2 MIDI is no problem - its just that i have no Gadget that talk DINsync and I’m not to keen designing something i can’t test . . . .


#506

not really something u need to test, 24ppqn and a pulse for start stop. im a bit of a freshman with the modular clock formats but a dual use of an existing socket seems like a good idea


#507

New firmware update here .

v0.94

  • implemented synchronous sequence switching: immediate or on sequence end

  • fixed ghost gate signals when step length is longer than sequence grid (/CV)

  • single Encoder B click while on the top level page shows Note page

  • double Encoder B click while on the top level page shows Seq Settings page

  • streamlined device Control Change events handling

  • sequence transposition is now reset on start


#508

TL1100 are out of stock both digikey and mouser.

Will 612-TL1100-6JBLK work?


#509

It seems like they are the same - but complete with some black cap? The datasheet says something about: Square Snap-on Actuator Head “L” Dimension is 7.5 mm


#510

It is not clear to me whether caps are removable or not?


#511

@cereyanlimusiki – yeah, it should… 612-TL1100-6JBLK seems to be the same part with black cap added.


#512

I am going to order today or tomorrow. I could add some and have a look.


#513

I can’t get the update to work. I have played the midialf_094_cv.syx to the MidiALF with several different softwares, Macs and MIDI interfaces - but the unit just restarts and still displays v0.93d.

What’s going wrong?
btw. Peter: I have never received the activation mail for your forum!


#514

@Mesmerised – please try to use longer delay between sysex messages, i’m using 250ms

Forum account activated, sorry for the delay.


#515

Hi Pete,
tried that. Even tried very slow transmission (took 5 mins) - no improvement.
Are there any error codes? I noticed that sometimes the first or second step LED lit up shortly.

Forum works now, thanks! :slight_smile:


#516

What software are you using to send the sysex to MidiALF ?


#517

I have tried SysEs Librarian (which I usually use for things like this) and the C6 you recommended.


#518

When you power up MidiALF while holding down Encoder A, does it enter firmware update mode? In this mode the MIDI LEDs blink a few times then MIDI IN is lit up steadily waiting for sysex data. The display is blank or displays a single line of block characters.


#519

It seems to do that, yes. I can’t check the MIDI LEDs since I have the CV-version where you’re not supposed to solder them in (as far as I understood it). The display shows white blocks on top and “black”/empty on the bottom row. How long do you need to wait for the unit to be ready to receive data? I tried keeping the button held for several seconds and waiting 10secs or so before sending midi.
The device promptly reboots after receiving the last Sysex string, but keeps always displaying the version 0.93d.


#520

The unit is ready to receive sysex within half a second after being powered up with EncA down.

If it reboots after finishing receiving a sysex it looks like it flashed what it received. I just checked the published .syx and it seems to be v0.94, any chance you’re somehow sending an older sysex file?