.mid firmware windows 7

Similar to the mac firmware issue. The two Shruti right buttons stay lit and do nothing. The ones to the left never lite. To make matters wo4rse its easy to find sysex senders but no to hex senders in midi and Windows 7 has no midi mapper ( bome/hubi/loopbe all tried and MIOS for sammichsid is too complex for a non-coder to figure out. So far sound forge pro 10, acid pro 6 and ableton 8 all will not send sysex loaded midi 0 format files. I tried a dos cakewalk and don’t use and wont get logic/ptrotools etc. So I’m stuck on v0.54. Is there any work around? Tried for two days and have the presets in mid and hex, sure could use sysex.

Try this file. If it works, I’ll add .syx to the firmware factory tool.

http://dl.dropbox.com/u/612135/shruti1-059.syx

Which MIDI interface do you use? I’ve tried a M-Audio Firewire 410 and it has a problem with SysEx. I’ve recorded the data it sends into another MIDI interface and discovered it duplicates or drops bytes.

Using an emu 0404 soundcard with midi cables. Windows 7 is a pain because it has no midimapper users can get to, so often the midi goes to a windows player internally. Ableton can get through this but doesn’t send sysex midi 0 files. Clunky that at my age I am still having issues getting midi out. Oh well. Thanks for the sysex, bome should send it.

Went with a new emu x midi 1x1 usb to midi cable which is plug and play with windows 7. with keyboard and load pressed on power up and 59.sysx coming from Bome’s sendsx I get the two alternating receiving chunks blinks and leds 1-4 slowly come on lit as receiving and the 64089 is sent. No odd midi speed used. I only get osc1-filter lit, not all eight in a row. LCD still blank, no ready for os upload message.

Then I get osc1/mixer/env1/lfo/arp/keyboard all lit. LCD screen remians blank and it stays that way.
I’m thinking I’ve lost the bootloader?

There are two ways of entering the MIDI update mode:

  • With the Shruti-1 normally powered on, by a long press on the Load/Save button.
  • With a press on the Load/Save button during power up.

“Ready for OS update” is displayed only in the first case (the bootloader doesn’t include a LCD driver).

As long as you have the last leds lit when you power it up with load/save pressed, the bootloader is still there. What seems to be happening is that the firmware is corrupted because some chunks of it were missing.

Try reducing the transmit speed to have at least 250ms of pause between packets. That’s why I prefer .mid over .syx: most SysEx transmit tool have a default speed which is too fast. The 8 LEDs should be lit.

midiox and bourne don’t seem to allow control on transmit speed and my other software doesn’t seem to send sysx in midi. I’ll keep looking for an editor. syx or mid I get 4 lights but not5/6/7/8 and the pulsing ones.

i couldn’t get any of my usual sysex progs (midiox and Bome) to send to the shurti correctly. Eventually what worked (and works) is just playing the file in cubase…