Mac Tutorial: How to compile and upload the firmware of MIs eurorack modules


#161

I think the policy here is that support requests for DIY builds of Mutable modules are discouraged. The DIY in your path suggests that this is for a DIY build. Try posting in the DIY section on Muffwigglers.


#162

Incorrect path to the toolchain.


#163

pichenettes> Incorrect path to the toolchain.

Yes, that was obvious from the error message, but I thought the policy was to not provide support for DIY module builds in this forum, and to suggest that such requests be posted elsewhere?


#164

It was faster to give the answer than to point to the policy.


#165

I know about your DIY and i respect it very much, you’ve done more than enough to our community ! I allowed myself to post here because you were talking about the exact problems i’m dealing with. Thanks again !


#166

*DIY policy


#167

And of course, the problem was i forgot a “/”


#168

After step 3.2. make install-cross, lots of activity for a few minutes then finish with these errors ?

ssembler-with-cpp -c …/…/…/…/…/gcc-4.8-2014.05/libgcc/config/arm/lib1funcs.S
make[5]: ***** [_arm_muldivdf3_s.o] Error 1
make[5]: ***** Waiting for unfinished jobs…
…/…/…/…/…/gcc-4.8-2014.05/libgcc/config/arm/ieee754-sf.S: Assembler messages:
…/…/…/…/…/gcc-4.8-2014.05/libgcc/config/arm/ieee754-sf.S:146: Error: invalid constant (fe) after fixup
make[5]: ***** [_arm_addsubsf3_s.o] Error 1
make[4]: ***** [multi-do] Error 1
make[3]: ***** [all-multi] Error 2
make[2]: ***** [all-target-libgcc] Error 2
make[1]: ***** [all] Error 2
make: ***** [cross-gcc-first] Error 2
tyronepowersPro:arm-eabi-toolchain-master tyronepower$


#169

@canecreek, insufficient information. Platform, OS version, etc? But seriously, why not use the vagrant VM that Olivier prepared? Presumably you are doing this with the intention of hacking the code? If so, much better to start with the known-good build environment that the vagrant VM provides.


#170

@canecreek I had the same problem compiling with jsnyder’s script on the latest OSX. We should file a bug report. Alternatively, you can download the pre-compiled toolchain from here (not recommended anymore, but still works fine).


#171

I’m running Yoshmite 10.10.5 2008 Mac Pro
(I can’t upgrade to el capitan as it doesn’t support Apogee Duet)

Im a total Noob and getting lost on every turn, I’m now trying the Vagrant method instead.

The Vagrant VM method.
Ive installed Virtualbox, Virtualbox extension & Vagrant.

Then I’m lost on the first instruction
To start the VM, open a terminal in the directory with the Vagrantfile and run: Vagrant up

So do i open the OSX terminal ?
or do i start up Virtualbox and open a terminal from there ? how do i do that ?


#172

Here’s how i do it.

  1. Open your terminal of choice

2. write “cd” without the quetation, and then drag and drop your ‘mutable-dev-enviroment-master’ folder into the term. that should give something like: “Jenss-MacBook-Pro:~ Jensu1$ cd /Users/Jensu1/Downloads/mutable-dev-environment-master” now press enter.

3. You are now in the mutable-dev directory. Now type in “vagrant up” without quotation and press enter. Virtualbox now starts in the terminal and if it’s the first time, you will see it update and download shitton of libraries and files.

4. When everything is downloaded, type “vagrant ssh”, and you should now be in the virtual machine and can start working.

See this for more commands to shut down, make and such: https://github.com/pichenettes/mutable-dev-environment/blob/master/README.md


#173

> So do i open the OSX terminal ?

Yes.


#174

Used Jensu again was getting Errors, so switched to an iMac 10.11.1 el capitan.

I’m getting the same error in both my Macs, so near yet so far

Last login: Tue Apr 19 11:22:08 on ttys000
tyrones-iMac:~ tyronepower$ cd /Users/tyronepower/Documents/arm-eabi-toolchain-master
tyrones-iMac:arm-eabi-toolchain-master tyronepower$ vagrant up
Bringing machine ‘default’ up with ‘virtualbox’ provider…
> default: Box ‘base’ could not be found. Attempting to find and install…
default: Box Provider: virtualbox
default: Box Version: >= 0
> default: Box file was not detected as metadata. Adding it directly…
==> default: Adding box ‘base’ (v0) for provider: virtualbox
default: Downloading: base
An error occurred while downloading the remote file. The error
message, if any, is reproduced below. Please fix this error and try
again.

Couldn’t open file /Users/tyronepower/Documents/arm-eabi-toolchain-master/base
tyrones-iMac:arm-eabi-toolchain-master tyronepower$

Thank you for you feedback guys…


#175

arm-eabi-toolchain-master ?? Have you tried to downloading fresh from here: https://github.com/pichenettes/mutable-dev-environment

Or am I misunderstanding what you are trying to do?


#176

Thank you Guys, and yes Jensu the fresh mutable-dev-env worked.

Now I’m wondering if the Mac is even seeing my ST-Link/v2 with various other issues I’m having.

After 2 days at this lol I’m going out with the wife for some fresh air and hopefully i can bend your ears somemore later.


#177

Make sure to read the ‘Using a different programmer’ part of the github readme. It doesn’t work with the st-link per default.


#178

She’s Alive, thank you everybody for your help its much appreciated.

Next mission : Elements…


#179

Wait, so it was a DIY build? You should not ask for help on here for DIY builds, go to muffwiggler for that.


#180

Hi,

Unfortunately my FTDI adaptor is not able to communicate with my Clouds.
My serial port looks like:
PGM_SERIAL_PORT ?= /dev/cu.Bluetooth-Incoming-Port

I guess it should be something called “USB-XXXX”

I’m using El Capitan and my adaptor is a Deek Robot like this one http://www.play-zone.ch/en/dk-ftdi-isp-breakout-3-3-5v.html

Do someone knows what could be wrong?