Mac Montery + Vagrant + GNU ARM tool and Mutable dev env

Hi there,

I’ve installed Vagrant for mac M1 (Rosetta 2 + VmWare provider) so i log to Vagrant successfully in the mutable env.

I’m trying to compile a bootloader code and have this issue :

**vagrant@vagrant** : **~/eurorack** $ make -f clouds/bootloader/makefile hex

/usr/local/arm-4.8.3/bin/arm-none-eabi-g++ -MM -g -O2 -Wall -Werror -Wno-unused-local-typedefs -Wno-strict-aliasing -fasm -finline -finline-functions-called-once -fdata-sections -ffunction-sections -fshort-enums -fno-move-loop-invariants -fno-unwind-tables -I. -DGCC_ARMCM4 -DSTM32F40_41xxx -DSTM32F4XX -DARM_MATH_CM4 -D__FPU_PRESENT -DNO_APPLICATION -DF_CPU=168000000L -DF_CRYSTAL=8000000L -DHSE_VALUE=8000000L -DUSE_STDPERIPH_DRIVER -DSYSCLK_FREQ_168MHz=168000000L -Istmlib/third_party/STM -Istmlib/third_party/STM/CMSIS/CM3_f4xx -Istmlib/third_party/STM/CMSIS/CM3_f4xx/startup/gcc -Istmlib/third_party/STM/STM32F4xx_StdPeriph_Driver/inc -mcpu=cortex-m4 -mthumb -mfloat-abi=hard -mfpu=fpv4-sp-d16 -mthumb-interwork -funroll-loops -fno-exceptions -fno-rtti clouds/bootloader/bootloader.cc -MF build/clouds_bootloader/bootloader.d -MT build/clouds_bootloader/bootloader.o

make: /usr/local/arm-4.8.3/bin/arm-none-eabi-g++: Command not found

stmlib/makefile.inc:373: build/clouds_bootloader/depends.mk: No such file or directory

make: *** [stmlib/makefile.inc:291: build/clouds_bootloader/bootloader.d] Error 127

It seems something missing in the PATH for compile with GCC so i installed the ARM toolchain to support floating pointi assume
.
I’ve checked with :

vagrant@vagrant:~/eurorack$ arm-none-eabi-g++ --version
arm-none-eabi-g++ (15:9-2019-q4-0ubuntu1) 9.2.1 20191025 (release) [ARM/arm-9-branch revision 277599]
Copyright (C) 2019 Free Software Foundation, Inc.
This is free software; see the source for copying conditions.  There is NO
warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.

so it’s ok but have the same error message.

Anyone got the same issue ?
Thanks

From what I understand here, gcc has not been installed correctly in the dev environment. I don’t know why.

You have installed it manually but then:

  • It’s not in the expected path.
  • It’s not the right version anyway!
  • Maybe you should try understanding why it did not get installed int he first place.

When the VM is created, is there an error message that could explain why the toolchain is not found and untar’ed?

Hi Emilie,
Thank you for the help.

If i’m running Vagrant in the mutable dev folder i’ve this error

➜  mutable-dev-environment git:(master) ✗ vagrant up
Bringing machine 'default' up with 'virtualbox' provider...
==> default: Checking if box 'ubuntu/trusty64' version '20190514.0.0' is up to date...
==> default: Clearing any previously set forwarded ports...
==> default: Fixed port collision for 22 => 2222. Now on port 2201.
==> default: Clearing any previously set network interfaces...
==> default: Preparing network interfaces based on configuration...
    default: Adapter 1: nat
==> default: Forwarding ports...
    default: 22 (guest) => 2201 (host) (adapter 1)
==> default: Booting VM...
There was an error while executing `VBoxManage`, a CLI used by Vagrant
for controlling VirtualBox. The command and stderr is shown below.

Command: ["startvm", "12ab698a-3e82-4c58-a729-12ce89587947", "--type", "headless"]

Stderr: VBoxManage: error: The virtual machine 'mutable-dev-environment_default_1650117085613_98784' has terminated unexpectedly during startup with exit code 1 (0x1)
VBoxManage: error: Details: code NS_ERROR_FAILURE (0x80004005), component MachineWrap, interface IMachine


I think mutable env is set with virtual box but when i start VBox outside it runs with Wmware provider and working good with amr arch 64 Mac M1 chips.

So i went to the vagrant config file and changed the provider to Vmware and also change the box to one supported by my machine as shown on Vagrant site ressources.

What is strange is that when i Vagrant up again in the Mutable dev env, the runing process still showing that he’s booting with VBox and ubuntu/trusty64’ box that i dont want.

Anyone have ever succeded to install the dev env with another Box provider than VBox ?

I’ve tried with an old mac on intel proc and it’s the same. It’s on Monterey