LCD not working

So I got my boards and soldered everything together, everything works, sound is good but LCD is dead. I’ve checked over my solder joints many times. All I get is one bright line and one dim line. I’ve tried another LCD I had laying around with no change either. Any ideas?

Did you trim the resistor like in step 13?

Yeah I’m 99% sure it’s not a contrast thing.

Next; Check the Trimmer if there are bad soldering joints.

Besides the LCD do the LEDs and switches seem to operate correctly?

Have a look at the PCB layout and check the continuity between each CPU pin and each LCD pin. Check for unwanted shorts between pins of the LCD module. Could it be a bent CPU pin that is not fitting well in the socket?

Yeah I’ll have to go though the pins and check connection. The switches seem to work fine and I get sound, so it seems fine except the lcd

There seems to be a bad (or fragile?) lot of ATMega644p in the last batch of kits, so if you have reasons to believe the chip is damaged, please return it to me, I’ll check it and send you a replacement if there is any problem with it.

Heh I’d love to, but too bad I self sourced this. Yeah I can’t understand this one, I even reburned the firmware. I get nice sound so obviously it’s working. I’m going to order a second 644p and see what happens.

on a side note removing a LCD with quickchip isn’t fun :stuck_out_tongue:

If I were to place the 644p in a breadboard and just wired up the LCD it should boot and show up correct? Just thinking if anything else besides the crystal is needed.

Also the Digi-Key part for the male 1x8 header listed on the Digital board build page is incorrect (3M9330-ND)

I’d imagine it should be something like this one: 3M9452-ND

The listed one is the wrong pitch.

Thanks, I have updated the BOM with your suggestion. Yes, if you breadboard the MCU, the crystal + caps, the LCD, and ground the first 4 ADC pins it should boot. If you do not ground the ADC pin you’ll see a lot of garbage on screen since it’ll read noise for the 4 pots.

OK cool I’ll test it out that way when I get home.

I have the same problem :/. Everything works fine (sound, LEDS) except for the LCD, who only shows a white line in the upper row. I’ve double checked all connections, tried changing the contrast and also unmounted the ATMega644p and no broken/bended pins so i dont know what to check… suggestions?

I had both times problems (cold soldering joint) with the TrimmerPot, maybe check this.

@Youmakeme: have you also sourced the parts yourself or is it a LCD module from the kit?

Maybe the extra tests Starfire will do on a breadboard will shed some light about what’s going on here.

It’s from the kit (2nd batch). Now i’m having fun trying to figure out how the synth works without any visual help so it’s not a big deal to wait for the tests.

Ok, i was looking through the patches and suddenly the LCD started to show strange symbols instead of the white blocks. They are most of the time “<-” , but there’s also “?”, white blocks and other symbols. It also seem to react when i move the knobs…any ideas?

The LCD will show strange patterns if it “misses” the configuration data the MCU sends at boot time. For example, if there’s a weak connection between the board and the LCD during boot, the LCD won’t receive the initial configuration sequence and will be unable to interpret correctly the data sent to it.

Check the continuity between all the MCU pins and the LCD pins, by referring on the traces image here:

Well the mystery continues! I got home and started testing pins from the chip to the LCD didn’t find any not working, so tried the LCD again and it worked! I have no idea on this one. I did nothing but test the continutiy of the traces and it magicly starts working, now it’s working ever since.

On a side note how do I go about getting all the defualt patches?

Play this syx / mid file into the Shruthi (with at least 150ms between blocks) to restore the 80 factory patches