Is My Rings Damaged?


#1

Sound is severely distorted when nothing is patched and when I feed a trigger to the strum input of my Rings. The distortions are gone as soon as a patch an empty cable into the V/Oct input. What is going on - Hardware defect? Firmware error? User error?

I tried to document the issue in this video here…

Any feedback appreciated. Otherwise, I will return this unit


#2

Sounds weird indeed. But one thing which is always worth doing before sending in a module: did you try to recalibrate it? I’d try that just to be sure.


#3

I did a calibration as described in the user manual. I don’t have a MIDI keyboard, but used exact 1V and 3V voltages from a voltage generator in the rack. The description of the calibration process in the manual is not very clear (do the voltages have to be on when you press the buttons or only inbetween?). I tried several interpretations, but nothing changed.


#4

Normalization detection issue. I’ve sent an explanation by email.


#5

CAnt you just post the answer here, I have a simerlar problem, more constant merzbow noise, but have ignored it cos once teh cv is in its totally gone and working fine, and I love my RIngs so much Id rather remember to patch the CV before the audio, than lose it for a day…


#6

I am having the same issue, is there a know solution???


#7

Contact the support team of Mutable Instruments. If it is the same issue, they will be able to provide solutions by email.


#8

Thanks for the reply