Installing Vagrant Environment?

New guy here, been lurking and reading though.
Trying to install the development environment on a WIn7 64bit box.
Installed Virtualbox, the extension and Vagrant.
Opened a command prompt and navigated to the location of the Vagrant file.
When running “Vagrant up” this is what I get.:

A possible cause is that your computer is not configured for virtualization.

For example…

I’m at work and will check this later today.

I will say that if I open the Oracle VM manager, I can apparently run the machine and log in with login:vagrant, password:vagrant

You SSH into vagrant, you dont login via VM manager

Thanks. I was pretty sure of that but I was trying to see if I had a virtual machine at all.
Honestly I am learning all this anew and I appreciate any help.

Without being able to check it right now, I was was wondering in my last comment if virtualization were not enabled would I be able to invoke the machine through the manager.

someone else had the VM being off in bios issue but I dont think the syntax was the same for what you are seeing, if you are running vagrant up for the first time, you should see a lot more output than that, it should take about 10 minutes to get going. If you were trying to get it going through VMware, kill that machine, that might be what’s interfering here. You dont need to do anything in VMware for this to work

To SSH into the VM, use a client like putty or bitvise and where the host is port 2222

Not sure what is up with my PC at home but I just did an install of everything and successfully built the clouds project on my laptop at work. Not sure if the VM is sharing the folders though. Can’t find it anywhere from the host.

it will clone the repo into whatever folder you put the vagrant file in. i.e. D:\\mutable-dev-environment-master\\eurorack-modules

From Windows 7, my vagrant file is in C:\\mutable-dev-environment
This is where I ran vagrant up

From the VM I have an Ububtu and Vagrant folder.
Below the Vagrant folder is the euroreach-modules folder

I can see \\eurorack-modules from the VM but not from WIndows 7.

there is no eurorack-modules folder? It should be there, vagrant uses the windows file system. You should see a .vargrant folder, some files (, .gitignore, Vagrantfile etc), and the eurorack-modules folder (cloned from git)

I see all those files and the .vagrant folder.
Below the .vagrant folder are folders \\machines\\default\\virtualbox
with several files being in the virtualbox folder.

I’m wondering if Virtualbox is not successfully sharing the eurorack-modules folder back to the Windows OS.

Or is it the other way? Windows OS is sharing the folder to the VM?

I know that during the install, I watched it and it looked like once Ubuntu was downloaded and installed, Vagrant brought up the VM then started cloning the repo etc. so I assumed it was installing all that in the VM to be shared with Windows.

You need to modify to have the code installed in a directory shared between the VM and Windows. I think someone made a change to the file recently that changed the default setting: it appears that the default setting is now a private folder, while it used to be a shared folder.

Thanks for that.
Does this mean an uninstall of everything then a reinstall or is it that simple?

How familiar are you with a command line?

And first: when you ssh into the VM, is there a /vagrant directory, and if you put stuff there, does it appear on your windows machine? I’m asking because VM <-> host sharing doesn’t appear to work well on Windows.

Not as familiar as I need to be for sure.
My wording might be wrong here but I went back to the root where I could see a lot of folders but not vagrant. When I cd to /home the vagrant folder was there.

I went ahead and deleted the VM from Virtualbox, uninstalled Virtualbox then reinstalled and ran vagrant up with the change made to

/vagrant folder is present now. Everything is fine. Folder is shared. I noticed that the vagrant folder below /home is still there also.

Thanks for your help.

Yes /home/vagrant is the home directory for the linux user “vagrant”. The codebase is just not installed there…

yikes. wasnt aware of the private folder thing, must be a new development. If you use bitvise as your SSH client, it will open a SFTP session by default where you can transfer files

OK, this is probably my final response on this as I was also successful on getting the environment installed on the original laptop that I have. This is what it took though and I have no real explanation.

1. Restored an image backup of the PC from about a year ago. Still got the same errors, vagrant would not authenticate.
2. Blew it all away and did a fresh install of Win7 32bit.
3. Vagrant had a new problem right off the bat and wouldn’t do anything. Wish I could remember the exact error message but I Googled it and installed some Microsoft Redistributable package and that fixed it. All is good and everything works.

Probably on step3 I should have let Win7 update to Service Pack1 and that would have also fixed the error. Anyway thank you guys for your great help.

Hi jkelly. What exactly did you change in the file?