Help me save a Shruthi-1

Hello, I was recently given a Shruthi-1 SMR4 mkII by a friend who started putting it together but, “never got it to work and probably broke it” according to his words. I am trying to get it up and running and after a few small successes I have run into a problem.

After moving some parts from incorrect spots/fixing bad solder joints I got the digital control board up and running but I can’t get any sound out of the output jack. The MIDI indicator on the LCD lights up, so it’s getting the MIDI data, and I get a click whenever the note-on signal is sent. I’ve been following some of the instructions in troubleshooting threads for the same “no sound” issue and I’ve traced the problem down to “test point #3” on the sound troubleshooting page, I get sound up until that point.

Many of the suggestions I’ve come across point to checking things around IC4, but here is where my concern lies – my friend did damage to the board at the area of the 100p cap just above IC4 (C10). The top of the board is clearly burned near the cap and the copper traces to the pads were broken and exposed on top of the board (he got it so hot that the pad came out of the board and broke the traces!). I used some part leads to recreate the traces on the under-side of the board per the schematics, but I’m not sure if that will alleviate the issue (see attached picture).

Tonight I will be verifying all resistor placements on the board and checking voltages on the ICs per these threads:



Any suggestions would be greatly appreciated as to my next steps of troubleshooting. Also please let me know if the damage to the board will prevent it from working properly? I’m familiar w/ circuit/electronic basics but am still very much a noob.

Thanks!

At first sight: C32 and C34 (the red 1nF film capacitors) are soldered in the wrong place. They have to be moved one hole up.

Alright, I verified the placement of all the resistors, they’re now all correct. Good eye cj55, thank you! I moved C32 and C34. While I was at it I touched up joints I thought looked suspicious. After testing the OSC signal again it’s still not getting to test point #3. I get signal up to the resistor bank below IC6. Not really sure where to look next.

I tested Voltage on IC4 pin 7 with the extremes of the cutoff like pichenettes suggests to others. I got 64mV when cutoff = 0 and -111mV when cutoff = 127. Not really sure what I’m measuring here though.

You could try giving your PCB a clean
Sometimes this solves problems but it will also but much clearer which solder joints are still not ok.
And next you could check that the right parts make the right connections. You can do this by putting your multimeter in continuity testing mode. Usually this looks like a small speaker or wifi kind of logo. Now it beeps if there is a electrical connection. Now test the connections on your board next to the schematic and or pictures of the pcb on the build page.