Help ambika plays mono only

It worked all 6 voices. It sat (with no enclosure) in my studio for a week. Now only voice one plays.
Tried setting it to Poly. Tried allocating voices.
Voice boards light up orange but the green LEDs don’t light up as they did before.
Could static electricity have messed it up?
What should I test for ?

Hi.
1.Check RN1against any cracks and dry joints.
2.check +/-8v voltage rail on not working voicecards.
3. Re-programming.
4.is any audio signal on connectors J3-J8?

Thanks for that quick help heniek. It works. Was just user error. I was allocating voices wrong.
I needed to assign them all to Part1 in order to play a chord. What a cool synth !

Oh yes. It is indeed :wink: you can also allocate notes range to particular Parts. It can silent some part of keyboard then.
Have a lot of fun.
Ps: Do you need enclosure by the way? I 've got some leftover.

I cut my own panel down from a serge sized aluminum & used saw + nibbler to cut the rectangle LOL. Its jenky but its workin. now to make a break out panel for outputs & midi.