Grids latency

I read that grids’ clock resolution and processing latency is very low (120µs) so i don’t get why I record the drums it triggers about 20ms later than if I use Pamela New Workout. I used the same drum module and the same 24ppqn clock source (coming from a passive multiple). I also made sure Grids’ clock input mode was set on 24ppqn. I wonder what i can be doing wrong, any clue anyone? Cheers!

I confirm that Grids latency is well below 1ms. Who would sell a sequencer module with a 20ms latency? Your problem is not a processing latency issue.

20ms looks suspiciously like the duration of one clock tick at 120 BPM. So it seems that Grids doesn’t receive the RESET signal in time (eg: it receives it after the first clock tick), and that your pattern is simply offset by one clock tick.

I am using an ERM Multiclock to generate the clock and the start/stop (gate on/gate off) signals. Those are then multiplied to PNW and Grids, but I am now realising now that Grids expects a trigger to reset, not a gate. I will try this out in a bit. Thanks for the help!

Grids resets on the rising edge of the RESET signal, so it doesn’t matter if this signal is a trigger or a gate. However, this reset must occur before the first clock tick of the pattern, and not simultaneously with the first clock tick.

So I could reset it already after the clock stops to have it ready for the next clock tick. I will also check if the ERM is sending the start rising edge after the first tick (that would be strange i believe).

I ran some tests, the clock seems good (raising edge prior to first tick).
I have the ERM Mutliclock calibrated with an offset of 8ms to compensate the latency (audiorate clock out > audio input round trip). When I disable this I get a consistent result (28ms delay).
recording



Any other idea what this can be caused by?

What’s your tempo? Again, I’m pretty sure that this is a 1 clock tick delay from Grids.

Okay I figured it out.

Tempo was 120 like you suspected so I ran some tests at 60 and 120bpm which caused the offset to change (both on PNW and Grids).
Ableton Live’s recording track “monitor” needed to be set to OFF to have synced recordings. Grids became immediately perfectly in sync and I even had to set the offset from the ERM Multiclock to 0ms :slight_smile:

I case someone is interested I also noted that for some reason PNW is triggering too early (this offset is still relative to tempo) when using my gate on/off signal in the RUN input when “RUN” mode is set to Y (“gate states clock state”). Setting it to RS (“trig in resets”) solved the problem.

All is now very tight, thank you very much for the great support!
Screenshot 2021-05-17 at 15.16.41

2 Likes

I sometimes find that when I’ve been recording using Grids (x 2) that the results are slightly off the beat (chain is Logic - MOTU MIDI Express via USB - Yarns - Pam’s New Workout - Grids); but I just select all the tracks and pull them into line. Works for me, and I usually blame USB MIDI anyway . . .